Open search

Samsung Email Version Issues

First Poster
My temporary solution is adding my Microsoft Exchange Active sync account to my Gmail app. Interestingly my phone is S8 on Bell network and my Microsoft Exchange Active sync account is Shaw and after the update it will will not send or forward any mail and it's not stuck anywhere.

Dear all, it is truer that in Samsung Store the actual version shown is the 5.x.xx.xx and no longer the


Now, how to rollback to it?

I tried everything.

1st try

I went to Manager App and clear data anda clear cach.

I unsinstall from there.

2nd try

I went to Manager App and clear data anda clear cach.

I unsinstall from Samsung Store

3rd try

I went to Manager App and clear data anda clear cach.

I unsinstall from Play Store

Here id doen not Uninstall and even if the option is available nothing happens


Each time after clear data and cache and uninstall I went to Samsung Store and install fresh from there the 5.x.xx.xx version.



It seams  this version is stick to the "firmware" and the base program is not cleared from the Note 8, and it always installed that last version and not the previous one we want to download.


Whate are your experiences or ideas on this?


Best Regards.


First Poster
Same issue here on Note 9
First Poster

I emailed Samsung and they just said to reset the phone - which did not help..


I bought the new s10 and the problem still exists.  and to boot they have made the version or whatever the base, it cannot be uninstalled like the previous models, so they have launched with a known broken product, very shamefull, I have voiced my dipleasure multiple times, they acknowledge the problem with exchange and I had to uninstall and re-install on my S8 to make it all work agin, BUT the S10 people are screwed for now I guess.


  The new Email version that was just released works perfectly    I just updated my Galaxy note 9 to the new Samsung One UI for Andriod pie..   The email is now sending emails and working on my Exchange Active Sync.


The previous version could have been rolled back,  which is what I did,  before this new update came out.   


Now it works fine.



First Poster

I also installed the point 63 version of the app and now EAS accounts work fine. 


My problem is that I can uninstall vesrsion. Nad before thar I clean Cache (but no access to clean Data - gray button).

Aftert uninstall I goto do Samsung Store and donwnlod neu version, it is done in 2 seconds ...

Whem I installl that new version the verison installed is the old "bad", like it is stucked in my phone ana does not accept a version with a lower number. It is so strange ...

I uninstalled and installed again, and allways the same, the come like a gost unwilling to depart.

Soem ideias to overcome this issue?Regards. Jose


Good morning, I've waited 24 hours since the above messages about a possible new version. I have not been able to find that version anywhere Play Store or anything. I am not convinced the did actually exists yet it has not updated on my phone either. I'm suspecting somebody just having fun with us.


I think you'll find that the email version you are offered depends on the Android version you are running. Like one of the other posters here, yesterday I upgraded my S8 to Android 9 (Pie) and I too am now being offered version I have so far refrained from upgrading as my current version ( works just fine and i prefer to see a few more reports on .63 before risking it. Before upgrading to Andriod 9 (Pie) - i had upgraded to the faulty version but managed to uninstall and reinstall the original working

Top Liked Authors