Support

Open search

S8+

Highlighted
SOLVED
First Poster

Good morning, why does my 4g/H symbol keep coming on and off when using wifi?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Superuser I
Superuser I

It'll happen when your Wi-Fi drops signal @Claired28 and it'll automatically switch to mobile data, if it's switched on. If you don't want it happening then simply switch off your mobile data when using Wi-Fi. 

View solution in original post

Highlighted
Superuser I
Superuser I

Hi @Claired28

 

You can change the set to us on your Samsung Galaxy s8+ so it does not try to change connection. 

 

Pull down your notification shade and long press on the Wi-Fi symbol. 

Choose advanced. 

Turn off 'Switch to Mobile Data

 

 

My advice comes from being a UK Samsung Phone User.
Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui 2.1 / Android 10.

Samsung Gear s3 Frontier Watch.
Samsung Galaxy Buds.
Samsung Galaxy Tab A {2016}SM-T580

View solution in original post

6 REPLIES 6
Highlighted
Superuser I
Superuser I

It'll happen when your Wi-Fi drops signal @Claired28 and it'll automatically switch to mobile data, if it's switched on. If you don't want it happening then simply switch off your mobile data when using Wi-Fi. 

View solution in original post

Highlighted
Moderator
Moderator
Hi @Claired28

It sounds like Smart Network Switch may be enabled, in which case you can disable this option by going to Settings > Connections > WiFi > Advanced > Smart Network Switch > Off. As advised by @John4Oh, you should also ensure that Mobile Data is disabled when connected to WiFi to prevent any unwanted connections.
Highlighted
First Poster
Thank you
Highlighted
First Poster
Thank you, can't find smart network switch though but it's ok I'll turn mobile data off when at home. Thanks again for your help
Highlighted
Superuser I
Superuser I

Hi @Claired28

 

You can change the set to us on your Samsung Galaxy s8+ so it does not try to change connection. 

 

Pull down your notification shade and long press on the Wi-Fi symbol. 

Choose advanced. 

Turn off 'Switch to Mobile Data

 

 

My advice comes from being a UK Samsung Phone User.
Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui 2.1 / Android 10.

Samsung Gear s3 Frontier Watch.
Samsung Galaxy Buds.
Samsung Galaxy Tab A {2016}SM-T580

View solution in original post

Highlighted
Explorer
Easy, when using WiFi, you're NOT using 4g/H, so the symbol drops.

When you're NOT using WiFi, or have a poor WiFi, 4g/H pops back because you're now using data.

There's nothing wrong, it's standard. If you've got it set to WiFi/boost, then you'll probably see 4g as now you're using BOTH.
Top Liked Authors