Support

Open search

S8 smart lock - trusted location issue

Explorer

No luck, had to unlock every time I used at home after going through those steps, gave up just doing the device proximity to keep it unlocked now, still sucks because it messes up the stuff I have set for geofencing

Highlighted
New Member

Trusted location I not working even after trying common fixes. Sending texts requires 3 bars of cellular service. Waiting for the Pexil 3

Apprentice

SOLUTION

None of these solutions worked for me BUT what did is setting my home address in the Samsung galaxy account.

It has been 2 days and smartlock still works.

I Hope it works for you too.

Google settings has nothing to so with smart lock.

Find "Galaxy Apps" amongst the rest of your apps. If you cant see it, search for it I am looking now for where to add your home adress but cant find where i went.

Ill come back with proper instructions when i find it again.

Just know that the solution is to add your home to actual samsung account. Ill be back when i remember how i did it. Im pretty sure it was in "galaxy apps" good luck and if someone else finds it, please post for others as this was a very annoyong issue

Explorer

Nothing has worked for me yet either, gonna try what you said, in galaxy apps click my apps, then email at the top then add address to Samsung account?

Apprentice

Hi Johnny, when you added your address to yout galaxy account service, that service gives that location to Google Map services. Trusted places means trusted places, not just home. 

 

I had my home address also registered but it did not help at all, because where I live the Google Map service sometimes locates me outside my house  when I am inside my home. 

 

I actually had to add two most common locations where Google Maps finds me most often when I am at home and now the system works most of the time. ; )

Apprentice

Sorry. I cant find where i did it but there was a google maps thing like when you add it normally but it was in my samsung acc somewhere. It was only 2 days ago. If you figure it out let me know as its. Bothering me now that i cant remember

Apprentice
Both Samsung and Google are really good at hiding those settings, every system update tries to bury that setting to even deeper and under a newly named category.

It is usually in "Settings" (cogwheel icon) and under some subcategory of category "Lock Screen and Security", in subcategory which name can also slighty change depending system version and Samsung's latest idea of usability =)
Apprentice

Ok got it.

Go into settings then

Cloud/apps

Select your samsung acc

(It will say your email underneath

Then click places and add your home.

Worked for me and is the only thing that did.

GOOD LUCK let me know how it goes

Apprentice

Still doesn't work with me, since phone sees me in different location where I actually am. 

Can you check closely time to time where your phone is located in  Google Maps. If the location dot stays in the same place all the time then it works, otherwise not. 

Whether the address is called home or work is irrelevant. 

Today my phone thinks persistently that I am not in those two locations what I have marked around my home to be recognised as my home, and the lock is not working again.

The saddest thing here is that there is no option to define the actual range around that located position that would always be considered safe. That would solve all these issues...

Apprentice

Have you tried holding the location button and ticking those box's for max accuracy?

Top Liked Authors