Support

Open search

S8 Calendar App will not sync

Highlighted
SOLVED
First Poster

Hi, I have two S8 phones (mine and wife) neither will update the calendar app from my Google account. I have cleared app memory and cache , restarted both phones but no luck. We also have two tablets on the same Google account which work fine. Can anyone help?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Member

I had the same problem, eventually, I was prompted to update my email and once I had done that then everything synced back to the way it was the day before. That's the problem with Samsung email, you are constantly having to update it.

View solution in original post

9 REPLIES 9
Highlighted
Superuser I
Superuser I

Hi @KevinM-H

 

I use the s8 and my calendars all sync. 

 

On checking my phones preferences they are set up as per on...

 

Launch Calendar App. 

Tap on the 3 little dots in top Rh corner. 

Manage Calendars. 

Is your address right where it says Google and is it toggled On. 

 

Pull down from the top of the phones screen to open up the Notification Shade and ensure 'Sync' is lit up. 

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui 2.0 / Android 10.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Highlighted
First Poster

Hi,

 

Thanks for the reply. I have checked all you mentioned and my settings agree. I have the problem on two S8 phones; mine and my wife's which sync to the same Google account. Same problem on both.

We also have two tablets (both Samsung) which also sync to the same account - both of these are working fine, so I know the account is good.

Puzzled by this but will keep investigating.

Highlighted
New Member

I had the same problem, eventually, I was prompted to update my email and once I had done that then everything synced back to the way it was the day before. That's the problem with Samsung email, you are constantly having to update it.

View solution in original post

Highlighted
First Poster

Still not worked for me even after updating my Samsung and google email apps.

JULIE STEVENS
Highlighted
First Poster

My "sync now" button was grayed out and it didn't sync for weeks. It turns out I had a power saver mode on and that was causing the problem. I had to turn off power saving and the "sync now" turned on and it auto-synced.

Highlighted
New Member

Checking the power setting solved the problem for me. I was frustrated that the sync button was grayed out but didn't connect that to the power setting. The power setting has to be at "Optimized" or "High" to be able to access the sync button. 

Highlighted
Observer

Thank you! This was it on my note 9. Very unintuitive  

Highlighted
New Member

OMG! I just changed power mode to optimized and it actually worked!!! Seemingly unrelated, unless Samsung Calendar requires more power to sync than Google Calendar. I might just switch to Google Calendar instead. That's weird!

Highlighted
First Poster
Mine works now, It was getting confused with different calanders, I think! Might have been a fluke that it's working.
JULIE STEVENS
Top Liked Authors