Open search


No fix as it not there problem you will be informed from Samsung & Virgin
To try this and that nothing works
Every time you contact someone you will receive the same incorrect details on how to rectify this fault that they will not acknowledge as a fault and will not accept that anyone else has had the same problem eventually you're just gonna give up the ghost. your post will be sidelined in a day or so and paranoia will set in.
First Poster



Ok so i did the same thing that BEEP did back on the 1/03/19.


Basically, went into my Virgin Superhub 3 settings using a web browser and typing in the IP address of the router, then signed in to the router back end. Once in, found the Wireless Signal settings and turned off 2.4Ghz and left 5Ghz on. I watched my phone automatically disconnect from the Wi-Fi and then reconnect itself.


The phone spent a whole half a day on the 5GHZ with no issues whatsoever. I only had to revert the router settings back to turning 2.4 on, because i discovered one device in my home, is still relying on 2.4 and cannot do 5Ghz. Sooooo.....again, Samsung what the hell is the fix for this? It would appear that the difference between a S8 and a S7 that both connect to a Virgin Superhub 3, is the S8 has no issues bouncing between the 2 ranges (if it even does this) and the S7 is falling over itself because it simply does not like 2.4Ghz. Sounds like a patch is needed to me?!!!

Hi Lee, glad that worked for you atleast somewhat, you'll find that it is possible to change devices settings and force them to operate under 5ghz..usually with older devices in the house or more budget devices 2.4ghz is the standard and cannot be changed.
The 5ghz channel will continue to work and will work around the bug.
All the best, thanks for your comment.
New Member
Same here. Virgin and S 7. C'mon Samsung. Sort it out
New Member
Just found the hub via the Virgin App. Took 2 seconds to find the choice of switching 2.4 or 5 off. Switched 2.4 off. So far so good.
Top Liked Authors