Support

Open search

S7 EXCLAMATION MARK ON WIFI SIGN

SOLVED
Apprentice

Hi, 

For the past few days my S7 has been continuously disconnecting from the WIFI and showing an exclamation mark on WIFI symbol; this disconnection is only occuring on my phone, my laptop and other devices seem to be completely fine; i have actually played youtube videos and run WIFI tests on my laptop while my S7 struggles to connect to the WIFI.

However, when I turn the WIFI on my S7 off and then on again, it seems to fuction completely normally for A FEW MINUTES but then goes back its disconnected state..

Ive tried running it in Safe Mode and then restarting it, this didnt work, ive tried to enable WIFI scanning and disable WIFI scanning to no avail.

In addition to these problems, when checking for a systems update, it tells me that "the daily download limit has been reached, try again later" so i updated it through Smart Switch which i hoped would fix these issues but did nothing at all, the update did complete with Smart Switch..

At this point im giving up and sort of running out of options.

The phone is a SM-G930F

If someone could help me I would honestly be so grateful..im missing work emails and other important things.

Thank you so much for your time

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

I figured out how to solve it..its basically based on the frequency of your phones WIFI connection..

You need to go into your router settings and block either the 2.4ghz frequency or the 5ghz frequency..

I recommend the 2.4ghz as it is slower but for longer distances.

The issue is with your phone..my phone aswell; for some reason it keeps malfuctioning and switching between 2.4ghz and 5ghz for no reason; therefore by disabling one option, you force the phone to transmit on one signal (either 2.4 or 5 depending on which you block).

Do it right now, block one of the two frequencies, forget the password for your router, reboot the router and then reconnect to it with your phone.

Ive basically just worked around it..it might however cause issues when you connect to another network that allows for two frequencies.



 

14 REPLIES 14
First Poster
I am getting the same problem with the wireless internet disconnecting. If anyone can find a working solution to this issue please let me know as this greatly affects my daily life as I use my phone commonly
Apprentice

I figured out how to solve it..its basically based on the frequency of your phones WIFI connection..

You need to go into your router settings and block either the 2.4ghz frequency or the 5ghz frequency..

I recommend the 2.4ghz as it is slower but for longer distances.

The issue is with your phone..my phone aswell; for some reason it keeps malfuctioning and switching between 2.4ghz and 5ghz for no reason; therefore by disabling one option, you force the phone to transmit on one signal (either 2.4 or 5 depending on which you block).

Do it right now, block one of the two frequencies, forget the password for your router, reboot the router and then reconnect to it with your phone.

Ive basically just worked around it..it might however cause issues when you connect to another network that allows for two frequencies.



 

First Poster

I don't have an option to manually assign a frequency so that won't work for me

Apprentice

Hm..you're going to have to find a way to manually force your phone to ONLY accept frequencies of either 2.4ghz or 5ghz.

That or..you put your router into modem mode and find an alternative router that allows you to restrict frequencies to one of the two that needs to be assigned.

Update me on your progress with either of these.

First Poster

I'm just gonna wait until they update it to fix it

Apprentice
Same happening to myself and my wife's phone think Samsung just wants you to buy a new phone
New Member

From past 1 n half months, the device connects to wifi and works for few minutes after that it shows no internet connection(! Mark). Reconnecting connects to internet but for few minutes. I had done network settings reset and also factory reset phone but issue persists.

Apprentice
Is this on all wi-fi or just your home network is your provider virgin if so I've tried every available resolution to no avail
First Poster

Hi people,

 

Same exact issue here in June 2019, and with exact same phone AND Virgin router! To put everything into perspective: Smart Tv's= connected via wifi/no issues, Samsung s8= no issue, Laptops and PC with wifi card=no issue, Samsung S7= connected but exclamation mark next to symbol and drops internet! This is clearly a issue with the S7 and as someone has mentioned like me, Virgin Superhub 3 routers. Whats the fix Samsung?????

Top Liked Authors