Open search

PIT file needed for Galaxy Note 8 - GT-N5120 16GB (Technical problem)

First Poster

Galaxy Note 8.0 GT-N5120 16GB (unlocked)
Flashed with a stock EE firmware (Working fine for years).


Hi there, I hope someone can help me as I'm having no luck sorting out my problem and I think it would be a simple fix.

On Sunday morning my tablet was plugged into the charger and on standby, but wasn't in use. I noticed it reboot for no reason. After it rebooted, it wouldn't load any further than the logo / model number screen. I hard rebooted it and encountered the same problem. I decided to take the back cover off and pull the battery. It's still having the same problem. I've tried just about everything else I know to get it to work. Finally I resorted to trying to restore the firmware via Kies. The process started but failed. I cannot get Kies to restore my device. Now I have no firmware installed, no recovery and the device can only boot as far as the Download screen. 

So now I'm trying to flash a stock UK firmware (N5120XXDOD1_N5120BTUDOD1_N5120XXDNH3_HOME.tar.md5 ) using Odin, but I'm having problems getting it to work. Odin Log reports:


  • <ID:0/004> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/004> Odin engine v(ID:3.1205)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> There is no PIT partition.
    <OSM> All threads completed. (succeed 0 / failed 1)


I've spent hours trawling the net for a suitable PIT file, but I can't find one, and of those I have tried, the links to the file no longer work.

Could anyone point me to a suitable PIT file to download? I know they can be extracted from another device of the same model if someone would be willing to ?

I would really appreciate any help with this.

Thank you, Chris.


Superuser I
Superuser I
Here it is mate (second post)

Just be cautious when downloading and installing stuff that ain’t official or from official places. *didn't see anything*



 Say "Hello!" to the Community in The Introduce Yourself Thread.

First Poster

Hi Leon,

Thanks for the reply. The following error message is returned from the link at XDA:
"The file link that you requested is not valid."

I think I've tried that link a few weeks ago and it was working then, however, I think it was a PIT file for the 8GB Note 8.0, not the 16GB which mine is.

I've still had zero luck with fixing it. I believe the NAND has failed. I reluctantly took it to a shop because, usually, if I can't fix something, it's unlikely that anyone else can, without the tools and parts required for major component level surgery. They had no luck with it either.

It's dead Jim!!

AntS  wrote:

Just be cautious when downloading and installing stuff that ain’t official or from official places. *didn't see anything*

Thanks. Understood!

Top Liked Authors