Support

Open search

Oreo update UK has anyone recived it yet

First Poster

Hi

i did on my note 8 about a week ago. This was on EE so i dont know if it was provider or phone specific?.

 

Explorer

I also recieved it on my note 8 one week ago - Unlocked samsung store version - using EE sim

Apprentice

Yes, not long after it was announced back in February.  My S8 bought SIM free from Samsung shop and running O2 SIM only contract.

 

Fairly easy install and few if any wrinkles since loaded.

Explorer

I know this is a few months later but I received the update 1/5/18 OTA from Samsung on my S7 edge and now my phone won't boot up. It gets stuck on the Samsung wording, it won't switch off either. I've tried soft reset and wiping cache but nothing. Having to travel miles to a Samsung repair centre to see if they can rectify without them wiping my entire phone. Anyone else had this issue? 

Explorer

Yup, exact same thing has happened to me. Phone is stuck on the Samsung logo and won't power off. Maddening!

First Poster

I've got exactly the same problem on my S7. 

Oreo downloaded yesterday and now phone on Samsung image screen. WontW shift.  Has been on it for 12 hours.  I've tried hard reset several times, phone just restarts to same Samsung screen. Extremely annoying! 30 mile trip to service centre coming up grrr.

Explorer

I managed to get mine working, eventually....

 

Stuck at Samsung logo --> Hold power and volume down to reboot

 

While rebooting --> Hold power, volume up and Home button --> phone will enter Recovery Mode --> Power off --> Remove SIM and SD card --> Power on --> Enter Recovery mode again --> Wipe Cache Partition --> Reboot --> Enter Recovery mode again --> Wipe data/Factory reset --> Reboot

 

Can't say this will work for everyone but did the trick for me. Obviously the phone was wiped so had to reinstall everything but thankfully it was all backed up. Phone is now working fine with the Oreo update installed.

 

Utter faff and I can't believe Samsung released an update that seems to be so problematic!

First Poster

I have just updated my Samsung Galaxy S7 to Oreo and now it is completely broken! It just keeps turning itself on and off in a loop, I cannot get it into recovery mode at all as it does not turn itself off completely. It was working fine before, no idea what to do!

Highlighted
Explorer

Have a look at the thread Samsung s7 Oreo update issues..many people have had same issue. I wrote a piece in that thread. Cheers 

Top Liked Authors