Support

Open search

Google play not working on J3

First Poster

I keep getting error message that Google play isn't working.

How do I fix it? 

7 REPLIES 7
Superuser I
Superuser I

Try a soft reboot by turning the phone off and on. 

 

Close down Play Store in your multi tasking and then relaunch. 

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

First Poster

thank you for your message but it hasn't worked, the message Google Play has stopped keeps appearing.

AntS Moderator
Moderator

Cheers for getting to this one, BandOfBrothers! :robothappy:

 

@Jeanette2: Following on from what BandOfBrothers said, is your phone on the latest software for it? Settings > Software Update.

 

Plus, have you tried clearing the cache and data from the Google Play app? Settings > Apps > 3 dots (top left hand side) > Show System apps > [scroll down and click into Google Play; or the name of the specific app that you're getting the error message for] > Storage > Clear cache, and Clear data.


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.


First Poster

Here's what you do:

Go to settings

then apps

then in the upper right corner click the menu dots

then select display/show system apps

then locate play store on the list

then click on it

now click on the menu up right and select uninstall updates, or similar

then when it returns to default version scroll down to permissions and open referring to changing system settings and revoke this permission

 

What all this does is return the play store app to the initial system version, which stops the error from occurring as it has to do with a bug in the latest version. What revoking the change system settings permission does is it stops the play store from updating itself to the latest buggy version. It will still install and update apps, but updating itself requires a deeper system access which is revoked as referenced previously.

 

Rejoice, now you have a bug free phone again. This is my original solution, haters gonna hate.

New Member

I've done done exactly that but it won't let me uninstall any suggestions 

New Member
I am exactly the same as previous contributor. It won't let me uninstall. Any help please this is a real nuisance!!!
New Member

Mine keeps saying it is installing but it has been saying this for  almost 24 hours. I can understand an hour or so but the phone is clearly not doing what it says.

Top Liked Authors