Open search

Galaxy Store isn't available in this country


Currently i'm in Kosovo, and the Galaxy Store says that it isn't available in this country. 

The store has a limited view, and it won't update the Samsung apps.

The same thing is happening on an S7, S8, and an A70.

I've tried taking the SIM out, turning off location for everything, and using a VPN to connect to the store.

When I do that, I get the full view of the store, but it still won't update the apps. 

When I go to update, the update page just doesn't open. It won't sign into the profile either.


Has anyone else had this problem?

AndrewL Moderator
@partin: It sounds as though your device wasn't intended for use in your current region. Can you confirm where you purchased your phone? Please be aware that Samsung devices feature software and hardware variances for compatibility purposes, and this can affect access to certain features of the device such as the app stores.

This issue is with All Samsung phones in Kosovo. Everything used to work perfectly until about 2 months ago, when they changed it. Also, this "variance for compatibility purposes" is not mentioned anywhere in the Samsung T&Cs. 

Some of my phones were purchased in the UK. I expect the phones to work as they in the UK wherever I am in the world. 


The other issue is, I have all my location services turned off, then when I am clearing the app cache&data, removing the SIM card, then using a VPN (connecting to the UK or the Netherlands or Germany) prior to opening Samsung Galaxy Store, it still doesn't work. This means that Samsung tracks our phones even though we turn location tracking off.  Is Samsung not respecting our privacy? What other explanation could there be?

First Poster

I think the problems started when Kosovo got its own phone prefix, the new +383 code, and it could be that Samsung doesn't recognize it yet.


Everything worked perfectly fine prior to the code change, and there were absolutely no restrictions whatsoever on any of the Samsung Services.


Now we can't login on our Samsung phones using our Samsung Account which means we can't use Samsung Apps, Galaxy Store says it's not available in your country and Theme Store is also not available.


I really hope Samsung will come up with a fix really soon, because this is so irritating.

First Poster

its same problem to me, Galaxy store isnt supported in our country Kosovo. I hope samsung can fix it as soon as possible. thnk u!

First Poster

I got an answer from Samsung. The phone is produced in South Korea which hasn't recognised Kosovo as a country. Ridiculous hahahahha.

First Poster

To me, they said "we are aware of the problem, and we require patience while we work on the problem". That was about 3 months ago and still nothing. This should not require this much time, but it seems that they do not care about this at all, and aren't even trying to fix it in the near future. I mean, Apple was able to fix the problems with the new code in weeks and iPhone owners had a much more serious problem.


Really dissapointed at Samsung about this.


The absurdity of the situation is even more jarring when I get notifications from the Galaxy Store about app updates!

So, regularly a few times a week, I get notified about updates, but I can't update them!  

But I can't uninstall those apps either, because they are core android/samsung apps. 

So, Samsung people, if you're reading this, pick something: either enable us to remove everything Samsung, or enable us to update them.


But I still have to bring up the point of Location Tracking. I haven't had the time, but I am going to send an complaint to the Information Commissioner's Office, so maybe they can have a deeper look into this situation (where I remove my SIM card, clear data from the Galaxy Store, connect through a UK VPN, and it still doesn't work).

First Poster
Same problem here. No solution
First Poster

good luck with that expectation of the phones working around the world as they do in the UK thing. Thats not how it actually works. It could very well be the CSC thats on your phone which is disallowing it from being used in that country. XDA has guides on how to flash a different CSC in Odin and the firmwares that contain the CSCs are available on

Top Liked Authors