Support

Open search

Galaxy S8+ manual APN setting?

SOLVED
Apprentice

I am on holiday in the US with my Belgian Galaxy S8+. I cannot use a US T-mobile SIM card because there does not appear to be a way to manually set the APN to T-mobile. The usual Mobile Networks option is missing from the Setup menus. Is there a way to manually set the APN...

or otherwise get around this issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Apprentice

Again for the third time, there is no "Mobile Networks" option under the "Connections" Setup menu.

I ended up going to a different US carrier SIM card and the APN apparently setup automatically so the phone works now.

View solution in original post

9 REPLIES 9
Superuser I
Superuser I
Hi,

Are you wanting to use your own Networks SIM card and Roam ?

If so and your own home network allows roaming in the country your visiting , and your roaming is turned on in your account with your own home network and they have roaming agreements / roaming partners then your phone should just connect.

To manually change Apns this link msy help > https://www.gottabemobile.com/how-to-change-galaxy-s8-apn-settings/

Alternatively if your phone is unlocked to All Networks then you could use a local SIM card. Typically when you insert the foreign networks SIM card it should then set up automatically or you'll receive set up texts.

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Apprentice
No, I am not trying to use my own Belgian SIM card and roam in the US. I am trying to use a local US SIM card from T-mobile with my unlocked phone purchased in Belgium.
Unfortunately the US SIM card is not setting up automatically so I need to manually set the APN. This option just does not seem to exist anywhere in the Setup menus. How can I set the APN manually when the automatic setup does not work?
Superuser I
Superuser I

Launch the link in my reply. 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Apprentice
Yes, I did look at the link on how to manually set the APN using the Settings. The Mobile Network selection that leads to the APN set up just does not exist anywhere within the Setting menus on my phone so the directions do not help.
Current phone Galaxy 8+, SM-G955F running Android 7.0
Highlighted
Superuser I
Superuser I

Settings > Connections > Mobile Networks > Access Point Names > Add. 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Apprentice

Again for the third time, there is no "Mobile Networks" option under the "Connections" Setup menu.

I ended up going to a different US carrier SIM card and the APN apparently setup automatically so the phone works now.

View solution in original post

First Poster
You are an *****.. I had to make an account to let you know.. How could you not see that this guy was saying that the option wasn't there.. Meaning.. Its missing... That means it isn't there.. How could he get to the setting when it isn't there.. How could you not understand that lol. Super user my ass
New Member

It's truly amazing people can be so thick. I have a similar phone. No problems with apn settings YET. But it doesn't work well with t-mobile....conflict between WiFi and VPN. So I got an S9+. Really should have canned Samsung after all that, but willmyphonework seemed to indicate the s9 will work on just about anything, all frequencies. Hopefully, I can use the S8 on Freedompop for free....

Have a good one!

New Member
I got the same phone. What a pos! Should just ****can Samsung' but got a used unlocked s9+ because willmyphonework seems to say the s9 will work on just about any carrier, any band. Hopefully, it will work ok with a free Freedompop account.
Top Liked Authors