Support

Open search

Dual Clock/Setting up Home timezone on Galaxy J7 Pro?

New Member

Hi everyone,

 

So after an incident with my Galaxy J7 I've had to get a new phone... so I got the same one (except this one is the J7 Pro)! I've been trying to set the new one up to match the settings I had in my previous one, and I've pretty much got everything except the dual clock on the lock screen. 

 

I bought the first phone back in my home country so when I moved abroad it automatically set the roaming/dual clock to appear on my lock screen display, which I found super useful. But now that I've started setting this phone up in what's technically my "roaming" timezone it perceives that as my "home" timezone no matter what I do! 

I've tried the Settings > Lock screen and security > Information and FaceWidgets > Roaming Clock route and used that to set up my home timezone but when I lock my phone it still only shows me my current timezone! I don't use Always On Display but that did give me the option for a dual/world clock and there was no way for me to switch my "home" country. Tried enabling that anyway, but still no dual clock on my home screen.

 

Is there any way for me to set this up the way I'd like it to without downloading third-party apps? I know it's such a small thing but I found it really handy for making calls back home, and it was so nice that it was all part of my phone's basic setup so I'd love to get it back!

3 REPLIES 3
Superuser I
Superuser I

Hi @moonbell

 

Taking into account phone' can have different features in respect to the model tyoe I use the s8 and under lock and screen and security I have...Screenshot_20180221-064404.jpg

 

 

Roaming clock. 

 

If you have no such setting etc then you may need to look at widgets / apps to see if one will fulfil your needs. 

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui 2.0 / Android 10.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Highlighted
First Poster

I have Samsung Galaxy J 7 Pro, in that i had set the home time and local time also and it was working nicely but suddenly the local time only on screen. But roaming clock is still turn on. How to rectify this problem? i need both local and home time on my screen. please anyone help  me.

New Member

Hi I have J7, and just found the following :

Settings > Lock Screen and Security > LOCK SCREEN, sub menu Information and FaceWidgets . Roaming Clock.

If you press the Screen on the LEFT where is says ON / OFF, NOT the slider, it goes into a further screen.

In there you can set the HOME Time ZONE.

 

Ensure Slider is ON also.

 

Top Liked Authors