Support

Open search

Cell Standby/Android System/Google Play Services battery drain for Oreo on S7

New Member

Contact samsung they will guide you through a few steps to put it right it happened to my friends s7 it was a pain but was sorted

Apprentice

The same issue for my Note Fan Edition. Cell Standby suck my battery. I use Oreo also and operator is Vodafone.

 

 

Explorer

@AntS With all due respect, but I don't buy it. Oreo was released for S7 after almost a year since that OS premiere and what Samsung developers did during that time? No beta tests? New OS should give us better battery performance, whilst most of us struggle to reach Nougat battery level. It's ridiculous.

Explorer

@Joakim wrote:

@AntS With all due respect, but I don't buy it. Oreo was released for S7 after almost a year since that OS premiere and what Samsung developers did during that time? No beta tests? New OS should give us better battery performance, whilst most of us struggle to reach Nougat battery level. It's ridiculous.


The funny part is that the very first release of Oreo for S7 may have been ok. I personally had no problems with battery life on Oreo until July update. So, initially everything may have been fine, but then they messed up something along the line.

First Poster

Hi all, 

I am here just to submit my complain with all the other S7 users above.

I am no longer happy with this android version because of the battery drain.

Reseting, flashing, updating...nothing solves the issue.

 

Please Samsung, we need to fix this.

Explorer

I got the update 4-5 days ago - big one (300MB or so). No change in battery life, only it no longer attributes the drain to cell standby only. I travelled to the Netherlands two days ago and drained two full charges in one day, which is quite horrible. If I interpret well what @AntS is saying, the higher drain is accross the board, so modem/bootloader flash shouldn't help.

So my decision at this point is to go back to Nougat. It will make quite a mess for me (most notably I'll lose my mBanking tokens) but at least the phone won't be betraying me at 5pm any longer. I'll give the modem flash a try since it's not time consuming and let you guys know if it helps.

First Poster

After the last update in Poland/Play mine is fixed. Phone is able to work for 2 days again. Today after 12h I've got 77% and stats say that battery should hold out for 1 day and 4hScreenshot_20180817-191652_Settings.jpg

 

 

 

Explorer

@Liamm wrote:

After the last update in Poland/Play mine is fixed. Phone is able to work for 2 days again. Today after 12h I've got 77% and stats say that battery should hold out for 1 day and 4hScreenshot_20180817-191652_Settings.jpg

 

 

 


I wish I could say the same thing about mine. I'm on the latest firmware and I'm still having issues...Screenshot_20180817-182402_Settings.jpg

 

 

 

First Poster

For whats it worth I used a solution posted earlier by Franky5 and it worked for me.

 

To start a I have a Verizon Galaxy s7 edge with Oreo. I have been plagued since the moment I upgraded the OS to Oreo with battery drain and a constantly hot device. My battery would only last 4-5 hours and the cell standby was responsible for 40-50% of that battery drain.

 

I tried wiping the cache first, monitoring the battery drain over a few days of usage - no success as the problem still existed. Then, I tried resetting to factory defaults, monitoring the battery drain over a few days of usage - no success. 

 

Then I came across Franky5's solution and decided to try it. To my amazement it seems to have worked for me. Franky5 suggested a couple of solutions but I only tried the following:

"Go to developer options (By clicking several times on build version, in software information) and changing the Background Process Limit, I set it to 3"

 

I've now tested this solution for a couple of days and my cell standby usage went from 40-50% to 2%. That's just amazing. My battery drain seems to be close to what I was getting on Nougat prior to the Oreo(although maybe still a little more that Nougat by 5-10%.) But a least with the fix I can make it through the day without needing to charge as I did with Nougat.

 

I have to admit something I found weird though. I went back into the Background Process Limit setting and it was set back to Standard Limit. I did not change it back to this, it changed magically. BUT, this battery drain problem did go away when I changed this setting and it has not returned even though the setting changed back. I haven't done anything else that may be responsible for solving the issue. I use my phone in the same physical area and my cell coverage/signal strength has been consistent throughout including using 4G.

 

Thanks to Franky5.

 

Explorer

@Tester3 wrote:

For whats it worth I used a solution posted earlier by Franky5 and it worked for me.

 

To start a I have a Verizon Galaxy s7 edge with Oreo. I have been plagued since the moment I upgraded the OS to Oreo with battery drain and a constantly hot device. My battery would only last 4-5 hours and the cell standby was responsible for 40-50% of that battery drain.

 

I tried wiping the cache first, monitoring the battery drain over a few days of usage - no success as the problem still existed. Then, I tried resetting to factory defaults, monitoring the battery drain over a few days of usage - no success. 

 

Then I came across Franky5's solution and decided to try it. To my amazement it seems to have worked for me. Franky5 suggested a couple of solutions but I only tried the following:

"Go to developer options (By clicking several times on build version, in software information) and changing the Background Process Limit, I set it to 3"

 

I've now tested this solution for a couple of days and my cell standby usage went from 40-50% to 2%. That's just amazing. My battery drain seems to be close to what I was getting on Nougat prior to the Oreo(although maybe still a little more that Nougat by 5-10%.) But a least with the fix I can make it through the day without needing to charge as I did with Nougat.

 

I have to admit something I found weird though. I went back into the Background Process Limit setting and it was set back to Standard Limit. I did not change it back to this, it changed magically. BUT, this battery drain problem did go away when I changed this setting and it has not returned even though the setting changed back. I haven't done anything else that may be responsible for solving the issue. I use my phone in the same physical area and my cell coverage/signal strength has been consistent throughout including using 4G.

 

Thanks to Franky5.

 


I've tried this, but unfortunately, it has made no difference :-(

Top Liked Authors