Support

Open search

Cell Standby/Android System/Google Play Services battery drain for Oreo on S7

Highlighted
Explorer

 

Explorer

Todays response from Samsung members support:

Screenshot_20180718-172147.png

 

 

 

Navigator
Hi all, I just noticed a new firmware for S7 with version G930FXXU2ERF6 (for France). Is there anyone that tried to flash this to see if something has changed compared to EREM or ERE8? security patches still on April though
Navigator

I'm gonna come in here and offer my 2 cents.  When I got my phone which wasn't that long ago it came with Nougat, straight away I updated it to Oreo so I had no previous experience of Nougat on the S7.  

 

I came from an A5 2017 which has Oreo and had excellent battery life.  Battery life on the S7 wasn't great, I came out of work with 40% battery life, on my A5 I had between 60-70% with the same usage.  

 

I then read reports of this Oreo bug on the S7 and thought that was the cause of my drain.  So I downgraded to Nougat.  At the moment I'm just home from work, 42% battery with the same usage I always have, Cell Standby is only at 1%.  

 

So for me anyway battery is ***** on the phone regardless of Nougat or Oreo compared to my old phone the A5 2017, I am using an S7E Exynos

First Poster
I have same problem on my a5 2017 after update oreo 8.0. after long time using facebook/youtube/etc, they usage battery only 3-4% but screen and cell standby show 30-40%. I think it was software bug.
Navigator

@Tanvir1 wrote:
I have same problem on my a5 2017 after update oreo 8.0. after long time using facebook/youtube/etc, they usage battery only 3-4% but screen and cell standby show 30-40%. I think it was software bug.

I never checked for this on the A5 2017, all I know is I did not have any battery problems regardless of what the readings said.

First Poster

were you on wifi the whole time? the issue happens only when mobile data is turned on and you're not on wifi. Try that for a whole  day and report back with the cell battery usage percent.

Navigator

@AndreiFrom83 wrote:

were you on wifi the whole time? the issue happens only when mobile data is turned on and you're not on wifi. Try that for a whole  day and report back with the cell battery usage percent.


Yes, I do not have Wifi at work only mobile data, so once I leave home at 7am no wifi until I get home again at 5pm.

Navigator

@mite_jan wrote:

new base for france ERF6 appeared

 

https://www.sammobile.com/firmwares/galaxy-s7-edge/SM-G935F/SFR/download/G935FXXU2ERF6/225462/


Yep, but this includes exactly the same modem (CP ERD6). So no fix of the bug yet, I guess.

Explorer

@dj1891 Have you considered that more powerfull and more power hungry S7 hardware would eat more battery than A5s????

Top Liked Authors