Support

Open search

A5 2017 speaker always on for calls.

Apprentice

My brand new phone always starts a call with speaker on. Applies to calls made or answered. Speaker icon doesn't indicate on. You need to toggle the speaker  icon once and it goes green to indicate correctly that speaker is on. Then press icon again to turn the speaker off. Can't see any settings to change this. Any ideas out there. Cheers. Mark.

8 REPLIES 8
Superuser I
Superuser I

@markybarky

 

Hi Mark, 

 

Let's try a few things buddy, first of all go to your S Voice app and go into the settings (the little cog icon) and switch off Auto start speakerphone and then reboot your phone.

 

If that hasn't worked then go into your Settings >Apps> Click the 3 little dots at the top of the right-hand corner and click Show system apps, then scroll down to Phone (the little green phone icon), there might be more than one Phone icon so do this in them all) click on the Phone icon and go to Storage and Clear Cashe and Data, also in the system apps you'll see the S Voice app icon, click on that and do the same in Storage clear the cashe and data, and again reboot your phone after this. 

 

If none of that works Mark I'd suggest a factory reset and that'll sort the issue for you, but try that only as a last resort. Let us know how you get on buddy.

Apprentice

Hi John. Thanks for the ideas. Did the S Voice first. It was set to autostart. It initially worked for just one call. Then cleared the caches on the 3 phone app's and the S Voice app. Didn't do the data because there is a strong warning comes up. Didn't work but having set a test call in progress to ear-piece operation it changed to speaker phone on its own after about 20 seconds. Is it safe to try again and delete the data regardless of the warning. Cheers. Mark

Superuser I
Superuser I

@markybarky

 

Yes it's safe to do Mark and don't worry only data related to the usage of the app will be cleared and not any contacts or anything, give it a try and reboot your phone, if that doesn't work I'd suggest the factory reset as the last option. 

Apprentice

Hi again. Cleared everything as you suggested. Again for a couple of calls it worked ok but then stopped working. Would it be safe to disable S Voice as a test. I dont think i need to use it. Cheers. Mark

Superuser I
Superuser I

@markybarky

 

Yes you can disable S Voice no problem, give it a shot and see if it helps.

Apprentice

That didn't work either. Looks like a factory reset. Thanks for the help. Much appreciated. Cheers. Mark

Superuser I
Superuser I

@markybarky

 

You're welcome Mark and unfortunately the factory reset is your last option, and please let me know if it worked ok.

New Member

This has been driving me crazy for weeks. I have looked at every setting on my phone a 100 times. Finally came across a thread that solved it - I have an app called Auto Call Record - call recorder and there is a setting called " auto speaker" - I made it off then it works well not even sure what the purpose of this setting is in the app.

Top Liked Authors