Support

Open search

A5 2017 WiFi hanging

Highlighted
SOLVED
Apprentice

The WiFi on my A5 2017 keeps hanging (starting / stopping) I have wiped the cache and done a factory reset but all to no avail has anyone had/solved this problem? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Pathfinder

No worries, was worth a try!

Now you've done the above steps can you change your router to 2.4 GHz then try again? ( I know you've already tried this.) Can you then remove/ 'Forget the Network' and reboot your phone again. Connect back to the router and give it another go! 

Keep me updated with the visit from the engineer, @mgne71

View solution in original post

46 REPLIES 46
Highlighted
Superuser I
Superuser I

Problem maybe not with the device try switching channels on the wifi on the router to one that on the other end of the scale, see how that works 1st.

Highlighted
Apprentice

@Bades1978 wrote:

Problem maybe not with the device try switching channels on the wifi on the router to one that on the other end of the scale, see how that works 1st.


Thanks for the advice I changed channel on both 2g and 5g bands but the problem is still present I've arranged for a new modem to be sent out from virgin media and will try that which should let me know if it's a modem problem I will update once the new modem is in place thanks again 

Highlighted
Superuser I
Superuser I

Ok no worries have a few more things to do after if it still exists  

Highlighted
First Poster

I just got a Samsung A5 2017 and it did the same thing. I talked to the internet supplier and they checked out the router and it is fine. So, I went back to the store where I bought it and they swapped out my phone with a new A5 2017.. Guess what... same issue. WiFi starts of smoke'n along. Then after a few minutes chug chug chug. Restart the phone and I'm off to the races again, for about 10 minutes or a short down load, then it goes back to the year 1998 and dial up speeds..... Things I've done:

 

1/ changed router channel

2/ forget and reinstall network

3/ reset network settings

4/ reset router

5/shut down phone and restart

 

Nothing works. WiFi works fine for a bit ( 12 Mbps ) then drops off to the last century speeds ( 130Kbs)

 

Samsung needs to fix this bug.

Highlighted
Pathfinder

Hey @Jacksbratt

Do you have Power saving mode turned on? Go to Settings > Battery > Power Saving Mode. Can you then check if you have Smart network switch enabled? This is a feature that will automatically switch from Wi-Fi to mobile data if the mobile data connection is more stable than your Wi-Fi connection. This could potentially slow down your connection if it's constantly switching out. Make sure this option is turned off. Here is how to do that: Swipe down from the top of the screen and pull down the notification shade > Next, tap and hold the Wi-Fi icon > In a new window, tap More > Smart network switch > Off.

 

If this still isn't working can you make sure the option 'Keep Wi-Fi on during sleep' is set to Always. Swipe from the top screen > Tap and hold Wi-Fi icon > More > Keep Wi-Fi on during sleep > Always.

After you've done all of this can you reboot your phone? Hold the 'Power' & 'Volume Down' buttons until the phone restarts. 

Are you still having issues with this, @mgne71? Could you also give the above steps a go? 

Highlighted
Apprentice

*edit

Screenshot_20170420-094012.png

 

 Thanks for the advice Jordan I have done the steps above at first I thought it had worked until I tried to add the photo and my wifi dropped again turned the wifi off and it uploaded no problem on 4G 

 

I have a Virgin Media Engineer coming out this afternoon to upgrade my broadband to 200mb with the latest Vivid hub V3 I will let you know how I get on 

 

 


 

Highlighted
Pathfinder

No worries, was worth a try!

Now you've done the above steps can you change your router to 2.4 GHz then try again? ( I know you've already tried this.) Can you then remove/ 'Forget the Network' and reboot your phone again. Connect back to the router and give it another go! 

Keep me updated with the visit from the engineer, @mgne71

View solution in original post

Highlighted
Apprentice

Hey Jordan by the time I got home the Engineer was already changing the modem so I couldn't test your last bit of advice prior to the change but I can confirm my wifi connection is now stable and not lagging (great for me) it was possibly a combination of the advice and modem? So I thank you greatfully for your help and hope others manage to rectify their problems 

Highlighted
First Poster

I have similar problem. My A5 (2017) wifi can't be turned on. It only keeps loading like in the pic. Even the smart network switch is disabled, which I can't do any. I restarted many times, doing device optimizing too but it still happens, I can't even find any access point, nor my modem nor my router, I think it's in the phone. :(

 

C_kEx6XUIAA0Kls.jpg_large.jpeg

 

 

C_kN0H0UMAAqQLC.jpg_large.jpeg

 

 

Top Liked Authors