Support

Open search

Unable to connect to Cloud server

SOLVED
First Poster

Hello.

 

Something wrong with the Samsung Cloud servers?

 

I have S6, S7, and Galaxy Tab S2, which are configured to backup to the Cloud and to sync the galleries across the three devices. That was working well enough, until recently the tablet started to flash a message at the bottom of the screen saying it was unable to connect to the cloud server. I thought it may be temporary, I'll figure it out when I have a moment.

 

But now the S6 and the S7 have also not been able to connect to the cloud servers. No backup, no gallery sync. Is something going on with the servers? Anybody else seeing this? This has been happening for maybe two weeks now.

 

Restarting the devices does not fix it. Clearing Samsung Cloud and Samsung Account data does not fix it. Removing the account and re-entering it does not fix it. It must be the servers, or is it my account?

1 ACCEPTED SOLUTION

Accepted Solutions
First Poster

Thanks for the help.

 

However, it turns out it was something router-related. I noticed that the Cloud connection was working fine on mobile data. A quick reboot of the router verified that it all came down to that.

 

Funny, never had a single problem with the router in two years, and even now everything else was working just as well as ever. Just the Samsung Cloud bit was having trouble connecting for whatever reason. If anyone can venture a guess as to the explanation, I'd be very interested to hear it, but other than that, the problem is solved for now.

3 REPLIES 3
Highlighted
Helping Hand
Hi Mthoth,

You can check out your Samsung Cloud contents at https://support.samsungcloud.com

This way you can look up your cloud contents via PC/Laptop etc. Try and see if you can reach your files via there.

---------
Never gonna give you up!
Mvg,
T.K.
First Poster

Thanks for the help.

 

However, it turns out it was something router-related. I noticed that the Cloud connection was working fine on mobile data. A quick reboot of the router verified that it all came down to that.

 

Funny, never had a single problem with the router in two years, and even now everything else was working just as well as ever. Just the Samsung Cloud bit was having trouble connecting for whatever reason. If anyone can venture a guess as to the explanation, I'd be very interested to hear it, but other than that, the problem is solved for now.

Navigator

@Talí wrote:

You can check out your Samsung Cloud contents at https://support.samsungcloud.com.

 

 

 

Awesome!

Top Liked Authors