Support

Open search

Galaxy S7 Samsung mail app not working after phone software update

First Poster

Hi TracyR

I cleared the cache and data as you described, and recreated my email account, but I still have the same problem. Most emails work fint, but some mails are never displayed when I try to open them and it looks as if it continues to load the mail. Some mails from the same company that are larger are show fine.

Please help.

Best regards Steven

Highlighted
New Member

I just found an odd fix for this, as I was having the same issue of emails perpetually loading but never seeing content - if I rotate my phone to landscape, the email body will suddenly appear, and will stay loaded when I rotate back to portrait. Not ideal and certainly a bug, but at least an easy workaround for now...

Apprentice

I recently came across another issue with my email not syncing and it turned out to be due to my phone memory being too full. Once I'd removed some photos and videos to make some space the issue resolved itself.

New Member

I have been having the same problem with my emails. Let me know if you come up with any fixes. I called Samsung and they didn't have any solutions at all.

New Member
Same for me.
First Poster

I've moved all my pictures from the phones internal memory the SD card. Even though the internal memory was fare from being full, it helped. Now all email are now being dispalyed again :-)

Samsungs mail app must have some problems when the internale memory is partly full.

New Member

Hi, 

I have a similar issue but not on the Galaxy S7. The Samsung Email App just stopped working. It is setup to sync using IMAP. Emails sent from the phone are displayed in the sent items on the server but not in the sent items on the phone. 

After clearing the cache, clearing the data, recreating the account and trying to resync the same issue occurs. I did check the power settings on the phone for background activity allowed as well as the storage available on the phone. Only 3 emails in Inbox and Sent Items displayed yet all are on the server. Using another application to sync to this account I am able to access ALL email. 

Any other ideas of what to do? 

Thanks 

Top Liked Authors