Open search

unable to format an 32Gb Evo micro sd card.

First Poster

Hi all,


I've got this orange-colored, micro sd card. I'm posting the backside photo of it. I just upgraded this old card from the Phone to a new 128Gb card with the idea of using the old 32Gb card in a Rasberry PI Linux based pc. The problem is that its not possible to format the old 32Gb Evo micro sd card. I've tried all the solutions on the net and nothing seems to work. It always comes up with some error related to Write Protection. Does anyone have any suggestions on how to fix this?


Thank you,


2020-01-15 12.26.37.jpg


Superuser I
Superuser I

Hi @nashero , can you take a picture from the opposite side please ?


Did you try to format this Micro SD card IN the original device like it is explain in the following post ?


Si j'ai pu vous aider un peu , cliquez sur le POUCE, Si j'ai résolu votre problème cliquez sur « Accepter comme solution » pour aider ceux qui se posent la même question. Merci
I f it help you a bit, click on the THUMB, If I solved your problem click on « Accept as a solution to help those who ask the same question. Thank you
First Poster

Here you go. This is the orange side of the card.


No I cannot put it in the old phone anymore, the old phone now has a 128Gb Evo and it is critical for my work. I cannot do this swap on it. I have the mSD and want to put it in a linux system. But I need to have the possibility to reformat it.



2020-01-15 12.27.19.jpg

Top Liked Authors