Open search

VPN PPTP Broken with HotSpot Galaxy S9

First Poster

Cool, thanks! Will this work on the S9+?

First Poster

Maybe in theory, but the direct link I provided on XDA were for the S9, so you will need to go to the firmware science main page and enter the build number for your device (in About>Software Information).  


Use the AT&T S9 Update site as a reference for the update path.!/stepbystep/id/stepbystep_KM1253489?make=Samsung&mode...


For the S9+ it goes:

1) G965USQU1ARB7


3) G965USQS2ARF4

4) G965USQU3ARG7

5) G965USQS3ARG8 


You must update in this order.  If you are still on RB7, then you can probably just update to RBI and then the other updates will happen on their own (it might take a day or so to get fully updated automatically, but you should be able to get RF4 immediately after you update). 


Also, be aware that after the manual update, my phone was reset.  It wasn't a big deal because part of my troubleshooting to fix it not updating was to do a reset. 


After I got RG8 PPTP vpn worked on my hotspot. 

First Poster

Interesting, when checking the software update information, it states that im on version:G965U1UES2ARF4/G96U1OYM2ARF4/G965U1UES2ARF4.


Note: Just saw your reply.

First Poster

In that case, I'd be hesitant to do the manual update (using the firmware science site, anyway) because they deviate from the AT&T update path.  If you enter RF4, they suggest an update to RF5, but AT&T went from RF4 ti RG7.



First Poster

Thanks for the heads up. I'm going to backup my phone and start the updating process. I'm hoping this will take care of the issue. I currently have a tp-link VPN router at home, which when I activate VPN on my phone, it works for about a minute and boots me off. I use L2TP/IPSec pre shared key as my security; I also troubleshot this by using my buddies VPN (same setting/router) on my phone. Still drops. Furthermore, he has an iPhoneX and has no issues when connecting to his or my set up. 

First Poster

No problem.  But you know the issue you're describing is a different issue than what is being discussed here, right?  I have no idea if the update to RG8 will help you, but I can confirm that RG8 fixes the issue where PPTP VPN connection fails from a computer that's using an S9 hotspot.


Anyway.  Good luck

First Poster

Yes, I'm aware; at the very least, it's the latest update avaliable...

New Member



I received OTA base version G960FXXS2BRH8

I was disappointed to see that, using this new version,  Access through VPN was still not working.

Afterwards, I enabled manually in phone settings: "Mobile Hotspot Protected Management Frames"

Now I can connect to my VPN.

You can found this option in mobile hotspot advanced configuration.

Hope it will works for you too.


Moderator, is this issue fixed yet? It's taking a severely unreasonable time to rectify! When is this going to be fixed?

I have a Samsung Galaxy S9 Plus 128GB Exynos Carphone Warehouse generic European version which is probably the most prevailant stock S9 Plus model after the retail version.

I have been experiencing severe issues where no VPN devices or services are detected and all devices and services shown are the devices on the current host network (hard wired/WiFi/mobile data) that im trying to use to connect to the VPN tunnel.


Even when I use 4G LTE to connect, doing a device scan comes up with the ports and services on the mobile network operator's equipment instead of the devices and services on the VPN that I'm supposedly connected to.

The only thing that appears to pass through the VPN is a "what's my IP" search through Google Chrome for mobile and visiting any reputable Who Is site, which report the external IP address of the connected VPN. Everything else appears to just bypass the VPN connection and be transmitted in the clear over the host Internet connection, which is unacceptable to say the least.


Even the connected VPN internal IP address is incorrect, reporting an IP address in the DHCP pool and subnet of the host connection's 192.168.254.X range, rather than the VPN assigned IP address in the 10.0.0.X range, which is worrying.

I have been using the OpenVPN Connect app from the Google Play store so nothing should be amiss here. On every other mobile device I am able to see a list of VPN connected devices only and not the services and devices on the host network that I'm using to connect to the VPN tunnel.

This issues needs prompt attention.


This bug is back with Android 9 ...


It's really a joke ...

Top Liked Authors