Open search



 the 2nd or 3rd I tried was a Samsung (ordered from Samsung not 3rd party) card.  So was the 5th. I actually bought a Samsung with the warrenty ya know guarantee if something goes wrong they will take and try to retrieve anything lost plus replace card either way. But after all the trouble Never did actually try to use it Lost to many files and photos already. Though the one app I put on did great job of saving at least a portion and got most off the s7edge that I dropped (it bitty set of short almost unnoticeable cracks where it hit a carafe for making candles and wouldnt ya know it knocked out like the digitizer or something hit right on power button First time I ever dropped any phone without couch or something soft to slow or land on and trashes whole thing my friend has same phone with about 100 large cracks from many times to floor cement ect his works fine) it saved files pics and movies from s7 s7 edge even rescued like 2 lost from s9+, out of 20 or 30 but it did rescue 2 lol. But I would recommend even with Samsung card back it all up first for safty 

First Poster

I've never had this issue with my S9+ and my Samsung Evo sd card.  I have noticed that this issue seems to occur 95% more with people that are coming from the Samsung Galxy S7 series...... Maybe, it's something in this phones setup of  sd cards that is causing the issue. Maybe the way it writes to the cards is specific to that series of phone..... just a thought


I'm not sure if it's something with the previous phone due to it working in my S9 for the past year.  I was thinking it was something that happened during the update from Oreo to Pie because that is when it stopped working.  But I'm no tech genius, just taking stabs at it.  I just didn't want to buy another SD card right now but I guess I will.  


It's one of those some people have the error/ write message or what ever some (like me ) have problems where pics end up just and exclamation point in middle of grey screen Then says no card in phone Put card anything else says corrupted or doesnt register there is one in at all. And some have no problem. I am coming from an s7 edge. Except I never used a card in my s7 edge or in the s7 I used for extra memory and between phones. Every memory card I have put in this phone was new never been in any other phone computer  or anything else. That and the last update also deleted several pics and not sure what else yet. I set to do later so could back up to computer and it started miniutes later when I went to get computer (and second I left room and couldnt delay it). I'm gonna get brave and as soon as get it all backed up hopefully today gonna put another new card in this beautiful door stop and cross fingers though will be forcing all pics to save to phone gallery NOT CARD hahaha WISH ME LUCK... and hope you get to be one the lucky ones that have zero problems with the cards..... have a wonderful day and even better week 

Ms Tony

Ms Tony's Whole New Universe


I completely get advanced as we are with technology sometimes it's the smallest things that become so irritating.  Good luck to you, and thanks you have a great week as well!


Hey guys, 


I decided to take the time to tell you guys about my last week ordeal. Like in my previous comment I have mentioned since I've got a new software update my read/write error message came back with a vengeance. For a couple of month it disappeared for some odd reason. Then there was the new update and there you go again. Anytime I touched anything on the phone the error message was up. 


Then I literally smashed the phone to the concrete so it was broken beyond repair. 

Thankfully like a dutiful paying customer I had insurance to cover the damage. So the company has provided me a 'refurbished, new like' handset. I don't even go into the ordeal how I actually have gotten the hold of this replacement phone. The most important is, that this phone had already an updated software and now the funny thing is that there is NO error message on this one. None. I repeat. NONE. I just put the old sd card into it, and I genuinely waited the error message to come up straight away. It never happened. 


I am pretty sure,this replacement phone has been properly fixed up, and it might be a newer version,not one from the first batch that my original s9+ was from.

I kind of feel lucky that my previous phone got broken.  I don't know what is the different with this phone,but certainly it feels like a good, quality phone. 


Wish I could offer a solution to other s9+ owners but this is my own experience and I am glad it seems it has been solved for me. 


Good luck to you all! 


I honestly think it is something to do with the softwares.

Unlocking the SD adapter, trying the CMD window on your PC, repairing or replacing the SD card, and checking your mobile device settings are the first solutions you should try to fix SD card. The operation of the CMD window: Win + R> Click "Enter" to open the CMD window > enter "diskpart" > click "Enter" to enter diskpart> enter "list disk" and click "Enter" (get the SD card number in the PC.) > enter "disk SD card number" > "Enter" > Enter "attributes disk clear read only" and click "Enter" > Finish.


What does the command prompt do?  And does it erase things on the card?  I bought a new card and transferred everything over, haven't had an issue.  I think it was something with the Pie update, as it was working well before and none of the files ended up corrupted or damaged.

New Member

I am having the same errors ... yesterday I stoped By spectrum got a new drive tray to hold both sim and sd. Just now got the error again. Phone has been restarted several time since yesterday but it took about 18 hrs to fail again....thinks I want a different phone.... been using Samsung for a long time.... 

Top Liked Authors