Support

Open search

S9 wifi keeps dropping, anyone have a solution?

SOLVED
First Poster

7 Months ago I bought a Samsung Galaxy S9 and have experienced the following problems:

 

  1. The wifi keeps dropping. An explanation mark appears next to wifi logo and wifi signal becomes unresponsive, and I have to switch off and on to get signal again. This happens x3-12 times a day. It only drops on my home router and works perfectly on other wifi routers. All other devices in home work perfectly on wifi router. It is only a problem between my S9 and my home wifi router.
  2. When I listen to radio via Bluetooth through wifi, even when wifi signal hasn’t dropped, radio keeps buffering. It will go silent, but sometimes if I press power button it will play again.

 

If I switch off wifi, all features of phone work perfectly on 4G including radio streaming. I am guessing the settings of S9 are somehow interfering with First Media wifi router or visa versa.

 

I have tried the following solutions, but none of them solved the problem:

 

  1. Reset network settings
  2. Deleted wifi connection and reconnected
  3. Deleted Network cache
  4. Factory reset of phone, at home and at service center
  5. Changed wifi settings from DHCP to static
  6. Service center replaced motherboard and then entire phone, the same problem persists with new S9 replacement
  7. Changed wifi channel of router
  8. Changed security settings of router from WPA-PSK/WPA2-PSK (AES) to WPA2-PSK (AES)
  9. My ISP said because wifi router works on other devices, the settings of S9 must be to blame

 

The fact that phone was replaced and problem persists, suggests it’s something to do with Samsung S9 settings.

 

Does anyone know a solution to this?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
First Poster

I didn't see an option on router to change to 5ghz, but various 2.4 Ghz options, previously it was in 2.4 ghz (B+G+N), I split to 2.4GHZ (B) and (G) and (N) but problem presisted, but then looking online I tried two things: Changed to 2.4Ghz (B+G) and at the same time disabled Hotspot 2.0 and since then my wifi works and has been stable, for 5 days now. Which of these two was the solution I don't know, but now my phone works.

 

Thanks for your input.

 

View solution in original post

3 REPLIES 3
Superuser I
Superuser I

Have you tried splitting the frequencies on your router to 2.4ghz and 5ghz and try then connecting the phone to one and then the other to see what happens @Tristan3451 

 

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

First Poster

I didn't see an option on router to change to 5ghz, but various 2.4 Ghz options, previously it was in 2.4 ghz (B+G+N), I split to 2.4GHZ (B) and (G) and (N) but problem presisted, but then looking online I tried two things: Changed to 2.4Ghz (B+G) and at the same time disabled Hotspot 2.0 and since then my wifi works and has been stable, for 5 days now. Which of these two was the solution I don't know, but now my phone works.

 

Thanks for your input.

 

View solution in original post

Highlighted
Superuser I
Superuser I

You're very welcome @Tristan3451  and am glad I managed to steer you in the right direction.

 

 

Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Top Liked Authors