Support

Open search

S9 wifi internet may not be available.

First Poster

I agree. The challenge with static ip, is it works fine if you only use 1 wifi. however for people that use multiple, it is absolutely retarded to expect them to set static addresses to get the wifi to work. it is 2018, you would think that a major provider like Samsung, or, as i have heard it may actually be Android not just Samsung, that Google would know how to implement a simple thing like DHCP and AP offloading?

 

I wait with baited breath to see if this gets resolved. However from reports i have read this has been around since Android 4.4 and up. So if that is the case, unfortunately maybe Apple is the only way to go.

First Poster

I'm one of the lucky bunch who doesn't get any wifi.

I've tried every tip here and nothing worked at all.

Please fix this. The phone is too expensive to fail like that...

First Poster
I got a new router from ATT. This one has dual bands with 2.4G & 5G. If you just roll the settings from your old router, it only rolls old settings to the old one (2.4G). The 5G remains in factory default.  Check your settings on your router, You may be trying to connect on the band that has the factory password. It's not your phone, you don't have to do in kinda funky ip setting stuff. Check your router. Find out what the name of the band is, rename it, change password and connect.

 

First Poster
I got a new router from ATT. This one has dual bands with 2.4G & 5G. If you just roll the settings from your old router, it only rolls old settings to the old one (2.4G). The 5G remains in factory default. Check your settings on your router, You may be trying to connect on the band that has the factory password. It's not your phone, you don't have to do in kinda funky ip setting stuff. Check your router. Find out what the name of the band is, rename it, change password and connect.
First Poster

You have wifi issues. Get the word out. My phone would not connect to my home wifi.
I got a new router from ATT. This one has dual bands with 2.4G & 5G. If you just roll the settings from your old router, it only rolls old settings to the old one (2.4G). The 5G remains in factory default. Check settings on router, Phone may be trying to connect on the band that has the factory password. It's not the phone, no one has to do in kinda funky ip setting stuff. Check router settings. Find out what the name of the band is, rename it, change password and connect.

First Poster

@Neotropic wrote:

Hi Guys,

 

Having same issue with S9+. So fro what iu can see the issue technically is not related to 2.4ghz or 5ghz, or at least not in my instance. What i have found is that any network that consists of more than one AP, with the same SSID, causes issues. It seems Android does not like the handover between devices with the sams SSID but differing MAC addresses. If i even use the same devices as the work network but set them up that each AP broadcasts a different MAC address, it works perfectly. The minute it is one unified network, multiple AP's with one SSID, it causes issues. This is a major issue with people who use their mobile devices for work purposes. Laptops, desktops and Apple devices have no issue with this configuration. I never had this issue with my S6.


This is exactly the issue I'm having.

Explorer

For a week 5 times wifi problem - internet is not available. 

 

My router is old. I do not have 5 Ghz.

 

I hope soon Samsung to fix this problem.

 

Samsung BRE3

New Member

I also have a similar issue. I have connected my ipone, Samsung S7 Edge, and the new S9 that i just bought to the same wifi network, and all the other phones are fine EXCEPT FOR THIS S9!!! it is super frustrating. and i  brought this to the samsung service center and they tried to do some system update or something, but up to now the issue is unresolved. so frustrating!!!

Explorer

BRF5 fixed this problem on my S9+.

Great work Samsung.

 

I hope Samsung will see the changes between BRF5 and BRF8. I am not 100% sure but I thing  BRF8  resurrect this bug.

 

BRF3 wifi bug - FAILED

BRF5 wifi bug was fixed - PASS

BRF8 wifi bug was resurrect again - FAILED

First Poster

Setting a static IP fixed the problem immediately for me. Not a practical solution though.

Top Liked Authors