Support

Open search

S9 wifi internet may not be available.

Explorer
Well, I thing bug was fixed with BRF8 but today I have problem again. Also my router is old and not have any 5Ghz. Wifi type is N. DHCP is active.
Explorer
No. This bug is not related with switching between 2Ghz and 5 Ghz wifi signal. I have old router with 2Ghz only and the problem is the same.
Explorer
No. I am with Linksys and have the same problem.
First Poster

I just bought an S9 to replace a Pixel 2 so I could move from Google Fi to Spectrum Mobile. My wireless was a mixed brand Access Point setup with 4 APs. When I got the S9, I noticed, with streaming audio, the internet dropping as I moved from one AP to another. The wireless signal was strong, just no internet connection. So, I figured it was time to upgrade my wireless, so I installed a Google WiFi four AP mesh system. I now have the same issue as before. When I switch from one area to another, the internet will drop unpredictably. I have many other devices available to test with. Two iPhones (5s and X), Google Pixel 2, HTC One; 2 laptops, a Samsung Chromebook, a Samsung Tablet, an old iPad, all of which switch between each access point without any interruption whatsoever. The problem is with the Samsung phone, pure and simple. The is either an antenna or a chip or software issue that prevents it from switching from one AP to another. I for one am not going to look for any more tweaks or workarounds, I returning the phone due to defects in materials or workmanship. Forgot to mention, I have a $29 burner phone that also switches flawlessly. The reason this problem is ongoing is because of the multiple access point home wireless model is just starting to ramp up and most people pass off this problem as a sub-par home wireless setup. I'm done.

First Poster

     

New Member

Changed to static IP one number away from the one router tried to assign me, preciously the issue 👍cheers mate

Eg. 192.168.1.128 X  (DHCP)

       192.168.1.129 ✓  (Static) 

New Member

After reading several pages of the issue (which I also had), you gave me the best diagnosis to troubleshoot the problem on my phone. 

My config is:  ATT Modem, Netgear Router dual-band, Samsung S9.

As soon as I went to the advanced options to try a fixed IP address on the phone, the DNS that was there was my router IP 10.0.0.1, instead of the classic Google DNS 8.8.8.8.

 

If I changed, it worked on the phone immediately (I always had internet, but no access to Google Play, and also the annoying warning). So the problem wasn't the phone, or the internet. The problem was that doing DHCP for some reason the DNS wasn't being assign as expected. So I checked my router config, and I had the wrong configuration in the DNS servers section, being 8.8.8.8 the second in the list instead of the first. 

 

Changed that in the Netgear router and immediately both 5G and 2.4G networks worked on the phone. No problems in a week since then.

 

 

Highlighted
First Poster

Update: I had 30 days to return the phone so I held off on returning so I could continue troubleshooting. I did 2 things, I switched to a Static IP and also (very important) reserved the Static IP in the router to prevent the DHCP from assigning it to another device. I also turned off the "Spectrum Wi-Fi Auto-connect" under Wi-Fi/Network Settings. Since I did this I have had no issues with the switching from AP to AP. For my situation, this workaround is totally acceptable.

First Poster

My solution was having to enable IPv6 and enabling DHCP for IPv6. I could not download from the Play Store and I was getting the internet not connecting error. I've had no issues since enabling IPv6.

Observer

Bluetooth deactivation not really related to this. At the moment that I deactivated the Bluetooth it just added 20% of speed on DHCP but when I statically configured the IP it went all in even with the Bluetooth activated. I don't know yet why but it connected to the 5GHz channel. 

Top Liked Authors