Support

Open search

S9 "update". And problems with mobile data.

Highlighted
SOLVED
Apprentice

Traveling in Europe. UK- some problems with data. France- no internet. Belgium- no internet. Netherlands- no internet. Germany- I have data. Poland- no data. Lithuania, Latvia- I have data. Estonia- no data. Finland- no data. And yes, I have tried to reload turn on/off phone, force stop some apps. Nothing helps. I haven't any problems in these countries before. And yes, I'm traveling a lot. And no, I don't want to reset back to factory settings, 'couse it will "update" back to the same *hitty "update". Any tips, becouse Samsung customer service to busy to solve problems?

1 ACCEPTED SOLUTION

Accepted Solutions
Explorer

This looks to me as if it could be related to your phone service provider rather than the phone itself.

 

The first things I would look at are the settings around   Network Operator to make sure that they are set up to automatically switch to partner networks in those countries.  I would also contact the service supplier to see if they have any suggestions.

9 REPLIES
Explorer

This looks to me as if it could be related to your phone service provider rather than the phone itself.

 

The first things I would look at are the settings around   Network Operator to make sure that they are set up to automatically switch to partner networks in those countries.  I would also contact the service supplier to see if they have any suggestions.

Apprentice

I'm using the same operator on 3 phones for more than 4 years. S7 and and S7 edge doesn't have these problems, becouse they aren't updated. All these phones connects to the same operator in all countries. "Home" operator blames Samsung and Google (Android), becouse I bought S9 from Samsung, not from phone operator.

First Poster

I am having the same problem in the UK, so no switching provider.  suddenly mobile data stops working for several hours wherever I am in the UK.  Big problem when this means, as it has twice in 3 days, I am using Google Maps as a satnav for a long drive.  As today, it worked up until around lunchtime, but I noticed no service at all switching back to mobile data from wifi.  I've driven for 4 hours, and still nothing.

Apprentice

Hi all I am having the same issue. The data connection unexpectedly stops working for several hours then comes back. Itn some cases it is not available for one or more days. It all started with the last update I received on Saturday the 7th of July. Is this happening to others as well?

Apprentice

Try manualy settings-> connections -> mobile networks -> access point names -> "network provider". That helped me.

Apprentice

It's ever since the last update that Samsung released. Turning off VoLTE calls fixed the issue for me.

 

Resetting the APN did for a while until I reconnected back on to my WIFI and then back to mobile data, then it wouldnt connect again.

 

Guess we'll have to wait for next months update and hope that there is a fix included.

Apprentice

I Will do what you suggested...it is Anyway frustrating

New Member
I have the exact same problem. I'll try this with the VolTe thanks for the idea
Apprentice

I tried and it worked for me so far

Top Liked Authors