Support

Open search

S9 phone keeps ringing on car Bluetooth after latest Android Pie update

SOLVED
Apprentice

 

I am having an ssue on my Jaguar XJ X351 after updating the S9 to Android Pie. If I get a call while driving and cancel/reject the call without answering, the car will continue ringing. Only way to stop is to disconnect the phone Bluetooth and reconnect.

 

I had no issues before the S9 Android Pie update. I also have a S8 which works fine.

 

Model SN-G960F

Build number PPR1.180610.011.G960FXXU2CSA2

BASEBAND G960FXXU2CRLI

 

I have tried so far

 

1. resetting the phone network settings and repairing

2. Clearing the cache partition via boot menu

 

 

Please fix this S9 issue asap.

1 ACCEPTED SOLUTION

Accepted Solutions
First Poster

Ok folks, I had another crack at this and fixed it (for my situation anyway) it seems to be Android Auto induced - this is what I did:

  1. Uninstalled Android Auto
  2. Unpaired phone from car
  3. Cleared Bluetooth cache, removed car pairing from phone.
  4. I THINK THIS IS IMPORTANT - While in Bluetooth settings on phone and with Android Auto still UNINSTALLED I went to Bluetooth/Advanced setting and switched Ringtone Sync OFF
  5. Re-paired (via Bluetooth only) phone with car - tested and it worked
  6. Connected car USB cable to phone and allowed the phone to promptme to re-install Android Auto - tested and it worked.

Since I did the above it has continued to behave itself. I belive the two most importatnt things are: reinstalling ANdroid Auto and switching off Ringtone Sync. I have noticed since I fixed it that I went back into Bluetooth/Advanced settings and the Ringtone Sync switch is disabled with the following message: "Not supported because Android Auto installed"

 

Good luck.

9 REPLIES 9
Pathfinder

Have you tried removing the pairing from both the phone and the car and then setting it up again?  I've had similar issues in the past and  this fixed it for me.

New Member

Same thing is happening with me!  Samsung Galaxy S9, Chevrolet Equinox w/ Android Auto.  I've reset factory defaults on the car, turned my phone on and off, uninstalled and reinstalled android auto.  The only way I can stop it ringing is to stop the car, turn off the engine and open the door.  Its maddening!!!!

Apprentice

Hi,

yes unpaired the phone and car. Also network reset the phone where it deletes all bluetooth devices and WiFi settings. Also somewhere there was suggestion to go into recovery mode on the phone and delete the cache partition. None of these fixed the issue.

 

Problem started since updating to Android Pie. I have another S8 phone this works fine.

First Poster

I have the same issue. Alpine stereo head in a current Mazda BT-50. At least it stops ringing for me when I hangup via the phone. Issue has only started today after updating to Android Pie last night.

Very annoying  

Highlighted
First Poster

I also own a Mazda BT-50 with the ALpine Head Unit and when I upgraded my S9 to the latest Android I got the same problem. Same as teh other Mazda owner - when I hang up the ringing stops.

 

I have tried:

  • Unpairing - clearing BT cache - repairing
  • Unpairing - resetting head unit - repairing

Neither of these worked - this continuous ringing happens both through Android Auto and when just connected via BT.

First Poster

Ok folks, I had another crack at this and fixed it (for my situation anyway) it seems to be Android Auto induced - this is what I did:

  1. Uninstalled Android Auto
  2. Unpaired phone from car
  3. Cleared Bluetooth cache, removed car pairing from phone.
  4. I THINK THIS IS IMPORTANT - While in Bluetooth settings on phone and with Android Auto still UNINSTALLED I went to Bluetooth/Advanced setting and switched Ringtone Sync OFF
  5. Re-paired (via Bluetooth only) phone with car - tested and it worked
  6. Connected car USB cable to phone and allowed the phone to promptme to re-install Android Auto - tested and it worked.

Since I did the above it has continued to behave itself. I belive the two most importatnt things are: reinstalling ANdroid Auto and switching off Ringtone Sync. I have noticed since I fixed it that I went back into Bluetooth/Advanced settings and the Ringtone Sync switch is disabled with the following message: "Not supported because Android Auto installed"

 

Good luck.

Apprentice
Many thanks Dave, your solution also worked for me. I didn't bother re-installing Android Auto afterwards in case it stopped working. Phone and car bluetooth seem to be working great.

Great work !
First Poster

Well done Dave 60 this worked for me 👍

New Member
That worked for me also!

That constant ringtone is/was really annoying.

I have a Samsung Galaxy Note 9 with Alpine iLX-F309. I'll share your resolution with my local Alpine dealer as they have had customers besides me that also have experienced this issue.
Top Liked Authors