Open search

S9+ no missed call alerts

Thanks this has worked for me. Thank you for posting
New Member

I too experienced this issue and was beyond frustrated.  I came across a suggestion by another owner of the S9+ on a different forum and found the suggestion to solve my problem (hopefully for you it works as well)!


Here's what I did: Settings< Notifications< Advanced (top right-hand corner)< Turn your contacts to "allowed"


I really hope this works.  For the amount of money paid for the S9+, it's shameful to have such a minor yet, important feature make it a dreadful purchase.


Good luck!

New Member
Harry, give this a try.
Setting> Notifications> Advanced (top right hand corner)> Turn your Contacts to "allowed"

Thanks but doesn’t work for me mine is already on allowed. 


Have you tried restarting the phone as be careful mine works with the spam protection on but as soon as I restart that’s it it goes again. So have to leave it off 


I cant believe Samsung have gone quiet on this like other problems reported on the forum I guess 


Have the same issue. 

Even with last firmware update, still there.

 Spam Protection on - No missed calls. Adding this to sillent calls... Well done Samsung! Great Job.

New Member

I am not getting notifications for calls. What's more is this expensive ***** phone isn't communicating with my Blaze again. 


This was reported as a problem on the 3rd April on here but it's highly likely Samsung were made aware of the issue before that. Its now the 14th May and it still hasn't been fixed!! As the primary role of the S9 is... Being a telephone, this is extremely poor. Is there any update as to when the S9's core function will work properly please 


This is ridiculous! 

New Member

Something that worked for me was to go to settings> Apps> contacts> scroll down to notifications under app settings and select allow.


Thank you but when that's already selected and it still doesn't work....

I can't believe Samsung still hasn't made this function as a phone! 

Top Liked Authors