Support

Open search

Pie removes the option to disable Bixby button?

Highlighted
Apprentice

Since upgrading to Pie I can no longer disable the Bixby button, which is incredibly frustrating since the buttom is rather stupidly located directly below the volume rocker button...

Anybody else found this? Any workaround? Many thanks. 

20 REPLIES 20
Superuser I
Superuser I

It seems the option to double press the Bixby button has been moved or removed @Craigmc 

 

I'll send feedback via the Samsung Members App. 

 

Could you do the same please?

 

Edit.

 

The double press option is still available in Bixby Voice Settings.

Screenshot_20190203-074629_Bixby Voice.jpg

 

 

 

 

 

Current Phone ~

Samsung Note 9 Model: SM-N960 Dual Hybrid 512Gb_ Samsung One Ui / Pie.

Samsung Gear s3 Frontier Watch
Samsung Galaxy Tab A {2016}SM-T580

Apprentice

I completely disabled this button in Oreo as I have absolutely no use for it, so why have I now been denied this option in the Pie update?

 

I do not want this button active in any way, so if anyone knows how I can completely disable it again I would greatly appreciate the advice.

 

Thanks in advance.

First Poster

Super easy to disable. Download BxActions from the playstore or get it from APKMirror.com. Follow the setup instruction to turn it off. Really simple. Or you can re map to literally any app. I have mine as LongPress: Flashlight / DoublePress:Camera (I turn off the quicklaunch on power button) and SinglePress&Hold:Google Assistant

Apprentice

Both Bixby and the button are by far the worst and most useless additions I've personally known on a mobile in 20 years.  I bought the S9+ knowing that I could disable the button and the insidious software could be cut down and disabled to a point - but now with the new update they are scraping the bottom of our personal data barrels - I hate it.  

Apprentice

That was just the job - cheers for the advice!

First Poster

As of 2019-02-21 BxActions reports that it does not yet support the Pie update that was just pushed out this week.

 

I detest that I paid a minor fortune for an unlocked phone and I still have to put up with invasive software that can't be disabled or uninstalled.  I will eventually look into rooting my phone (ha...like I have time to fiddle with my phone even more), but I have been able to reclaim some of my sanity and some semblence of control over Bixby.  I performed the following steps some time ago, and just checked and all of these to make sure that the Pie update didn't undo my changes, which it hadn't.

 

Open Settings>Apps and then choose the 3 dots in the upper right corner.

Select "Show system apps".

Scroll down until you see anything that begins with "Bixby".

Tap the icon for each entry and scroll down to App Settings.

Tap Permissions.

Touch every item to change the little slider to the off position.

Go to previous screen, and select Notifications.

Turn off the slider.

Go to previous screen.

Select Appear on top.

Turn off the slider.

 

Follow this procedure for any entry that starts with "Bixby", as there are 6 such entries in my S9+.

 

Some of the app detail screens show an entry for "Change system settings" under Advanced.

If present, selct this item and switch the slider to "off".

 

Basically, you just deny Bixby access to everything you can.

 

The first time you do this, it might be a good idea to restart your phone, and then double check these entries for good measure.  When I did this the first time about a year ago, Bixby shut up.  Only time will tell if that's the case with this new update, especially since there now seems to be no way to completely disable the Bixby button without an effective update to BxActions.  I will keep checking the Google Apps page for the update to BxActions.

 

I have done as the above post suggested and used the Bixby settings to set my Bixby button to a double press.

 

Good luck all!

 

CF

 

 

Apprentice
Many thanks for the advice, mate. Some of mine still needed turning off, so that really came in handy!
Apprentice

Sadly it doesn't seem to be possible to fully disable top Bixby button. The best I can find it to change the setting to require a double click. This hardly helps in preventing Bixby being activated when the button is accidentally pressed. 

Must say that I'm not a fan of the S9. I prefer my old A5.

First Poster
I went into Bixby settings and changed the setting to open Bixby with the button from 1 press to 2 presses. At least it does not open when you hit it by mistake once instead of volume down. Helps a little. I also turned off the voice activation because I could not use voice commands (like- capture, smile, cheese, etc to take photos on my 9+with that turned on.
Top Liked Authors