Support

Open search

Not connecting to mobile data S9

ChrisM Moderator
Moderator

Great to hear, @Jo0! Thanks for keeping us informed.

First Poster

Hi I have a samsung s9 and pay as u go but it's coming up enable to connect to my we network everything else working but can't make calls says no nstwork

Highlighted
First Poster

Wow...this actually fixed it right away. Awesome and thank you. I've been searching for hours on how to fix it.

New Member

Hi i need help my s9 is not connecting to data i thinng i need something like *#no....#...

Explorer

@Jc19801 wrote:

Hi I have a samsung s9 and pay as u go but it's coming up enable to connect to my we network everything else working but can't make calls says no nstwork


 

That's likely due to either

- phone not activated

- phone IMEI flagged as lost/stolen and blocked (blacklisted) at network level (check with provider or pay for a check on https://checkmend.com)

- problem with SIM

- cancelled SIM or account (check with service provider!)

 

If you bought the phone second hand and it's a grey import, you'll need to activate it with a SIM card from a territory which the phone is intended for. All Samsung phones are region locked. See this thread for more info:

 

https://eu.community.samsung.com/t5/Galaxy-S9-S9/Galaxy-S9-region-lock/td-p/531869

Explorer
To resolve this thread, after this problem was discussed, the next Samsung monthly update fixed this problem, at least for my S9.
First Poster

I have the s9+ with the same problem of not connecting to mobile data when leaving a wifi area.... there is no ability on the phone to turn the volte on or off on this phone so why does everyone keep referring to it. I've had 3 phones replaced and I still have the problem....

Explorer

If your firmware & device supports VoLTE, you'll find it here (Android Pie, One UI):

swipe down from top of screen -> cog menu -> Connections -> Mobile Networks -> "VoLTE calls SIM 1 enable/disable"

 

Wi-Fi Calling:

Phone dialer -> three dot menu in top-right corner -> Settings

 

If you can't see it, VoLTE isn't available as an option either due to your provider restricting the feature or it not being available on your particular hardware revision. Don't ask me why it's not universally available, I think it's as stupid as you do

 

Disable Wi-Fi Calling and see if your mobile data starts working when leaving a wifi network. If it does, check you have the latest monthly update, as this was an issue for me and other S9 users until Samsung pushed out a patch with the February 2019 update.

First Poster

Thanks for your answers but obviously I don't have Volte settings on my phone and not sure if Samsung just incoporated it into there software so you can't turn it on or off as suggested. Only once did I see an Volte setting up in the connection area so it must be there. As far as turning the wifi off when leaving my home wifi, the phone will connect then to 4g but again once I go back inside I would have to go through the process of turning wifi back on. Obviously, this is what I'm trying to get away from. Wife has an S5 Samsung it works perfectly fine going from wifi to 4g and back. So far Samsung and AT&T again are of no help and on my 3rd replacement phone. All software is up to date.

Explorer
Unfortunately, if you got your phone via AT&T, it may be running a version of software specific to them where they've crippled the VoLTE features or modified its behaviour somehow.

What software update is your device running? Does it receive the monthly updates? My SIM-free S9 had this issue out of the box, but a monthly update fixed it.

AT&T repeatedly sending you replacement devices sounds like their first line support is clueless - they should be escalating it to their Android team. Unfortunately if it's a carrier provided handset, Samsung will likely be unable/willing to help directly and will probably direct you back to AT&T...
Top Liked Authors