Open search

Mirrorlink - s9+

First Poster

I am trying to use mirror link on my Galaxy s9+ but it doesnot work. More specificlly,  I connect the phone with usb cable to the car and the mirror link is shown on my phone display. In car display the connection is established but when I select any of the apps such as carmode, lg car mode, Sygic, RockScout, etc. I am getting following error: The app cannot be used while the vehicle is moving. However the car is stopped and even I tried it with engine off.

I tried the car with Galaxy note 9 and Iphone 6 and both are working fine.

I appreciate if you can assist me in this problem.

New Member

I have the same problem on the S 10+

First Poster

Honestly, it didn't fix until I got new updates from Android. Then the problem never happened again.

However, try two things:
1. Put your handbrake on and check if the problem exists if yes go to step 2
2. Try to install AndroidAuto and use it instead of the mirror link



First Poster

Hello I use this thread for another S9+ and Mirrorlink issue. I use Sygic Car navigation in S9+. Connection via Mirrorlink is ok, but after voice from navigation, sound of tuner or media is lost. If I switch to radio and back to navigation, radio is back but after few seconds situasion is same, no sound. If I disconnect phone from Smartlink, sound is back self. Does anyone have any experience with this issue ?


I use S8+ and I use this process. I recorded this if it helps you:

In the future also you might get the certficate issue with Mirrorlink. Here is the solution:

I knew what I discovered would be useful somehow.

I came here just so you guys can try. I have a S8+ and a Peugeot 2008 17/17 with Mirrorlink connection and I was using all normally until few days ago. I started to get the message of Certificate Not Valid for this App.

What I did? Go to SETTINGS>>APPLICATIONS and check the SHOW SYSTEM FILE. Search for Samsung Mirrorlink 1.1 and delete CACHE and DATA.

Once I connected to my car again I noticed the message wasn't being shown anymore. With the phone connected, I tap on the screen and saw there was a message "Mirrorlink needs to use Data to download a file" (or something aroudn those lines. I tap AGREE and the file was downloaded.

Removed the device and reconnected and VOIALA! Mirrorlink was working again.

Also for everyone with Samsung and mirrorlink, try to use this process I video taped:

I hope this helps someone. I got so happy I can use mirrorlink again in my car.
Top Liked Authors