Support

Open search

How to Turn Off Screen Wake From Text Message

Apprentice

My problem with my new Samsung Galaxy S9+ is that with the stock Messages app that comes on the phone, how do I turn off the SCREEN WAKE feature that is automatically set on the phone for Text Messages??? I do not have a problem with the text preview and the notification icon being placed on the Always On display, but what I do not like/want is for the screen to automatically wake up for those brief 2-3 seconds when I get a new text message. This ONLY happens from a new text message. Any other app, when I get a notification, the screen stays off, and will just vibrate or play the set sound I have, and will display the notification icon for me to see when I myself turn on the screen. The Messages app is the ONLY app that screen wakes the phone upon an incoming text message and that is annoying. And none of the suggested steps regarding the Always On Display or settings within the Messages app turn off this feature. Is turning it off even possible??? PLEASE HELP

15 REPLIES 15
TracyR Moderator
Moderator

Hey @jmitch2428

 

You can try: Messages > More (Three Dots) > Notifications > More Settings In App > Preview Message > Off

 

 

Sherlock 2.jpg
Say "hello!" and
 
Introduce Yourself, or virtually hangout in the Samsung Lounge

Apprentice

I'm pretty sure I tried that and it still happened. It's just prevented me from seeing the text in the LOCK SCREEN, but the screen still woke up. 

Apprentice

Yup, I just tried that, turned off the PREVIEW MESSAGE switch and it still did it. All that does is prevent me from seeing what the text entails from the lock screen.  But the screen still lights up quickly when the text is receive. 

 

I don't have a problem seeing what the text says, I just DO NOT want the screen to light up and auto screen wake when a new text is received....

TracyR Moderator
Moderator

No worries, 

 

Try this;

Settings > Sound and Vibrations > Do Not Disturb > (Click on the words instead of the slider) > Hide Visual Notifications > Hide When Screen Is On > On,

Then go back > Allow Exceptions > Custom > Calls From > All.

Also make sure 'Event/task alerts' and 'Reminders' are turned on so you don't miss those.

 

Before you leave this section, make sure you toggle Do Not Disturb to 'On' so the settings go into effect. 

 

 

Sherlock 2.jpg
Say "hello!" and
 
Introduce Yourself, or virtually hangout in the Samsung Lounge

Apprentice

In doing this, will I still receive the Lock Screen notifications and have the vibration and/or sound play when I receive the new text? 

Apprentice

Nope. Screen Wake still happening...

First Poster

I been looking for my phone screen to wake up on my so plus how can I do it to make it work?

First Poster

this spec... fu**ing annoying behavior is happening to me too ... and it's enough for me!

 

Device:
Samsung Galaxy S8 + G955F

Application:
Samsung Messages

Solution process:

  • Change the rights / notification settings for the application
  • Resetting all settings (Reset-Reset Settings)
  • Factory reset
  • Forced phone update (g955fxxu4cri1) / Forced message updates (5.0.40.15)

none  of that helped!

So I went to Google Messages

 

https://www.reddit.com/r/GalaxyS8/comments/9kejzn/s8_message_wake_up_lock_screen_sms/

First Poster

Hi, I was having the same problem so if you don't mind changing your messaging app I'd recommend getting Textra from the playstore.

It's a really nice messaging app and you can set it so it will not wake the screen when you get messages while still allowing for the notification sound and flashing LED light. The setting to turn off wake screen is: open the app, click on the 3 tiny vertical dots that are at the top right of screen and select Settings>Customize Notifications>Wake Up Screen>>>   Click on Wake Up Screen and select NO and that should solve the problem. 

Top Liked Authors