Support

Open search

Google Assistant intermittent with Android Auto

Highlighted
First Poster

Hi all,

 

Since updating to Android 9.0 I'm getting a very frustrating issue with the google assistant and Android auto.  My phone correctly connects to my car (Hyundai Ioniq), and Android auto loads without issue.  All apps within Android auto work perfectly, and all music/navigation comes through the speakers perfectly.  

 

If I activate google assistant with OK Google, the phone correctly listens and takes the command through the car microphone.  However, when I press the voice activation button on the steering wheel (or the mic symbol within android auto on the car screen), the Google Assistant dots appear, but 90% of the time they don't listen (they don't respond when you talk, and if you leave it they just time out).  There is no real consistency to this, if you press the button ten times in a row it will probably work one of those times.  I have tried doing it with the phone locked/unlocked and it makes no difference.  If you make a change within the google voice settings it seems to work on the next attempt, and then goes back to being rubbish again.

 

I feel happy it's not the car, as my iPhone works perfectly with Apple Car play everytime, at any speed, and Android Auto worked perfectly pre-update

 

I have tried turning the various google assistant settings on and off (work over bluetooth, with wired headsets etc...), and I also completed a total factory reset of the phone which hasn't made a blind bit of difference.  Everything worked perfectly pre-update

 

Any help would be much appreciated

 

Thanks in advance

A

Top Liked Authors