Support

Open search

Galaxy S9 Plus wifi speed issue

New Member

Hi 

I had a Samsung s8plus and would always get a speed of between 300 to 350 no problem at all.

Moved over to the new S9plus and I get between 125 to the best being 180 and that's on the 5G network even on 4G the same.

 

PLEASE SAMSUNG TAKE NOTE AND GIVE US A ANSWER OR A UPDATE FIX PLEASE 

New Member

Same issue, turning off the bluToothe did nothing on s9+

Just Browsing

Indeed, after turning off the bluetooth i get the desired (max) speed on my home wifi. With my wife's Note 4 i always get the max wifi speed. It is UNACCEPTABLE to get low wifi speed with the flagship of Samsung (S9 plus) unless i turn off the bluetooth. I really need the bluetooth always on because i use it a lot. Samsung you must take action to solve this problem.

First Poster

turning off bluetooth helps instantly, but have gear s3 watch and plantronics egde headset :(

First Poster

Ive the same issue s9plus doesnt work on wifi when bluetooth is ON, how the f... ? It possible

Can someone from Samsung look at that ? 

New Member

I have had this issues for 2 months. Replaced modem, took phone into Geek squad, nothing. Crazy thing, when geek squad connected it to their wifi, phone was super fast. As soon as I left, some thing. I have done all the recommendations 4 times now and no change. Even my data is super slow. 

New Member

I have Wifi mesh network in my home and 100mbit/s internet connection. My wifi works on MacOS and PC perfect, but in my Samsung s9+ there is massive speed problems!! At first I got about 60 mbit/s but speed slows down sometimes below 5 mbit/s. When I test it from Mac OS speed is continuesly about 90 mbit/s. This is really bad problem! because I have to use wifi connection that I can connect other devides in my network. This is my last phone from Samsung if you cant do nothing to this issue!!

First Poster

I'm am to experiencing the issue not good at all.

First Poster
Same here.
First Poster

I had the same issue and here is what I did to fix it:

Hold down on the WiFi network and select network settings, then advanced options then IP settings and change it to static

Top Liked Authors