Support

Open search

Galaxy S9 Plus wifi speed issue

First Poster

Where is the patch for this problem.

First Poster

yeah, buyll***** isnt, Samsung should be shame, 

 

anyway if you switch to 5G wifif instead of 2.4hz its working proper unfortunately not everywhere is 5g

Observer

Hey guys, was testing my Wi-Fi speeds today on my S9, and it seemed like I couldn't get more than ~40Mbps regardless of 2.4GHz or 5GHz, which didn't seem right as my other devices consistently achieve 100Mbps.

 

After experimenting, it turns out Ookla's Speedtest app is bugged. Other speed test apps correctly show my speeds, whereas Speedtest is maxing me out at 40Mbps. Seems to be the case on my iPhone as well. Just posting my experience, sorry if it didn't fix yours! 

New Member

Hello, I had the same problem. I went to an internet provider and he changed my router's frequency from 2.4 to 5 G and the problem was solved. I hope this is a permanent solution.

First Poster

Download 1.1.1.1 from the play store. I use this and it sorts the slow wifi issue out on my S9 while it's active.

https://play.google.com/store/apps/details?id=com.cloudflare.onedotonedotonedotone

First Poster
THIS IS IT! Removing mouse (Mi mouse) from connected Bluetooth devices solve the problem for me. Thank you!
New Member

Changing my IP to static helped  

Observer

I was also experiencing slow wifi on 2.4 Ghz on my S9.  Turning off bluetooth would restore the internet speed immediately.   Seeing the comments on the MX/MI Mouse causing issues,  I tried removing an old BT pairing to a Garmin activity tracker.  After removing the connection, my wifi speeds seem normal again (and leaving BT on).  I hope the faster speeds continue...I really don't want to be disabling BT when connecting to wifi.

 

This still sounds like a Samsung issue to me but removing the old BT pairing is working for now.  

First Poster

Hello. I resolved my problem with Samsung s9+ and Samsung Watch. Major problem was very slow wifi speed when watch connected. I was tried everything including re-pairing, factory restoring watch ect. Turn off watch updates on Samsung Wearable app on your phone. Settings->about watch->backup and restore->backup settings and try to off auto backup. Unchecking that option completly resolve my wifi speed problem. 

Highlighted
First Poster

When S9 connecteed to home network (Wifi), kills whole network. Seems auto sync and auto backup are culprits. Disabeling them would help 

 

 

https://forum.xda-developers.com/galaxy-s9/help/sudden-wi-fi-speed-slow-t3877133

Top Liked Authors