Support

Open search

Fingerprint sensor with 3rd party apps (paypal etc)

First Poster

So I've just got a new S9+ (previously had a S7 edge) and it works great apart from one annoying "bug" (which may not be the phones fault)

 

The fingerprint reader isn't working with 3rd party apps (banking app, PayPal etc)

It DOES work fine (and fast) to unlock the phone so I know the sensor isn't faulty but when I try to log in to the PayPal app with my fingerprint it just instantly switches to password log in - no error message... My banking app (Natwest - a UK bank) does give an error message "Sorry fingerprint login has failed due to a system error" and I then have to use a passcode to login.

 

Things I've tried:

1. Checked for updates (all up to date)
2. Turned off smart gestures
3. Removed my fingerprints and re-added them.
4. Done a diagnostic of the sensor - shows working fine

 

Any help / suggestions?

 

Thanks

 

Tony

7 REPLIES 7
Explorer

UK user here too. PayPal and Clydesdale bank and others work fine for me with fingerprint.  Never had an issue and haven't had to do anything additional to get this to work. 

 

1. The only thing I can think of is to check your app permissions. Although, don't think there is an option for fingerprint scanner permission. Worth a look.

 

2. Uninstalling and reinstalling the app.  Probably the best option.

 

3. Factory reset (last resort) potentially might be a glitch somewhere; doing this might clear it. Mind to back up data etc. 

Pathfinder

It's working fine for me too - also a uK user.

 

The only other thing I can think of to add to @Biker74 is to try enabling Samsung Pass (under LockScreen and Security in Settings)

New Member

Hi, I am having the exact same problem, did you manage to find a solution?

First Poster

Go to the banking app using your Passover, when logged in touch the little man at the top right, opm settings, turn fingerprint off and then back on, exit the app, log in again with your passcode, the fingerprint option should now be working again. 

First Poster

I can confirm that this solution works. 

First Poster
Thanks! Worked for me too!
New Member
Cheers man! This has bugged me forever. I have uninstalled/ reinstalled once to no avail. Thanks!
Top Liked Authors