Support

Open search

Can't switch from Wifi to Mobile data automatically

New Member

Hi guys, I also have the S9+ dual sim and had the same problem yesterday. Sorted by turning off VoLTE calls from Settings/Mobile Networks and also Data Roaming switched off. And now the internet works just fine when I leave my wifi from home. Let me know if it worked for you also...

Highlighted
Apprentice

My VoLTE option was on so I've turned this off. Thanks for the tip, will update if it works. Maybe an incompatibility with my network

Explorer

@Anghelu2001 @xxmicrocutsxx 

Hope this solves your issue because on my phone that option to choose to enable/disable voLTE or voWifi is not available.Depends from the region that the phone is used.I tried many approaches but no luck,hope this solves your problem permanently...

New Member

This is the problem for my S9+ aswel

New Member
It's work perfect now.Thank you.
Explorer

What worked,?Disabling the voWifi amd voLTE?

 

Apprentice

I can confirm switching off VoLTE calls has temporarily fixed this issue for me which coincidently started after the latest update from Samsung which was apparently for Google now.

 

I hope Samsung are listening to this and get a fix out sharpish.

 

And for those asking, my phone is S9 Plus 128Gb single sim version.

Apprentice

I can also confirm that switching off VoLTE has fixed the issue (for today atleast!). Hopefully this is a bug Samsung can iron out in their next update. I will let customer support know that this is an issue

Observer

I've had the same ridiculous issue and have been been scouring the internet for the last 2 hours looking for an answer. I've come across this post and it was the only thing I've found that's worked so I've set up a Samsung community account just to come on here and say thanks Anghelu2001

New Member

Having exactly the same problem:

1. S9+ dual sim - SM-G965F 

2. Yup, downloaded 20th June

-This might be causing the problem because in Settings>Connections i dont see disable voWifi. -> wifi calling is under call settings (open dialpad, 3 dots to select settings, wi-fi calling down bottom)

3. Sim 1 - 3, Sim 2 - O2

4. UK

 

Just disabled voLTE so going to check to see if this is the cause.

Top Liked Authors