Support

Open search

Can't switch from Wifi to Mobile data automatically

SOLVED
Explorer

(Samsung S9+)When i'm connected on Wifi everything works fine,but when i get out of range it switches to mobile data but no internet is available.I see that there is no ip address also.I have to swith to airplane mode on then off ,then the phone will conect on mobile data.Anyone else has or had this issue?It's annoying,i'm planning to return this phon if this issue is unsolvable.

1 ACCEPTED SOLUTION

Accepted Solutions
Explorer

Here is a temporary solution that works.

 

Depending where you live some of the options for disabling or enabling voWiFi or voLTE might not be accessible.

Solution 1: disable voLTE and voWiFi 

Solution 2:(If settings not accesible)  Just use 2g/3g (Autoconnect) the problem is with the 4G.

 

Hope samsung will patch this issue.

50 REPLIES 50
ChrisM Moderator
Moderator

Hi @DreadyH. 

 

Are you still having this issue with your phone? If so, have you tried any troubleshooting steps to resolve it?

Explorer

Hello again,

Forgot to write down the actions i did before i posted my problem here.

1.First i made an software update was hoping that it will solve the issue but it didn't.

2.because i had some appliactions installed(tought they might be making the problem) master reset.Still no luck

3.The mobile network providers sent me certificates for internet/mms (T-home) No luck again.

4.Addaptive WiFi (Normal or aggresive mode) it still has this isssue.(Was hoping that this will solve it.

5.Then another update was available.Installed it (Did not manage to fix this issue).

6.Out of ideas and searched the whole web for a solution but with no luck...

 

P.S Turning Off Wifi or Turning Off/On mobile data does not solve the issue either.Only putting in airplane mode and back again...

ChrisM Moderator
Moderator

Hi @Dready.

 

You've mentioned a master reset. Did you do a full factory data reset on the phone? If so, it sounds like you'll need to let one of our engineers take a look. You can find your nearest Support Centre here.

Highlighted
Explorer

Thanks for the reply.I'll try my luck in the shop,i'll ask for a new phone or a full refund.Thanks for your time and effort.

ChrisM Moderator
Moderator

Our pleasure, @Dready. Let us know how you get on.

Explorer

It has been 6 days since i left my phone at the repair shop (It's an official Samsung repair shop) and they have no clue what is the problem with the phone.

First Poster

I have the exact same problem. Seems like it only happens to me when I use Wifi exclusively for some extended time like a day or so. Short term (up to maybe a few hours, I didn't measure the time needed) of Wifi usage doesn't cause this. I restart my phone and the mobile data works just fine.

Explorer

Hello Again...

Im trying to find more people having this problem.Please report this problem to samsung also...

I think i know what the problem is..

1Can you please tell me do you have Samsung Galaxy S9+ with Dual sim?

2.Have you installed the latest patch that includes voWifi and voLTE?

-This might be causing the problem because in Settings>Connections i dont see disable voWifi..

3.Do you use t-mobile sim card?

4.What country are you from because where i live most of the setting are limited by default(dont know why)

 

P.S You dont need to restart your phone every time but you can turn airplane mode on and off...this is a temporary fix so you don't need to restart your phone all the time

 

First Poster

1. I have the single SIM SM-G965F model.
2. I have the latest update installed. (Version G965FXXU1BRE6/G965FOXM1BRE3/G965FXXU1BRE3

3 & 4. I am from Turkey so I don't use T-Mobile.

Top Liked Authors