Support

Open search

Bluetooth doesn't work after PIE

First Poster

I'm having the same problem with my Jeep wrangler. It seems that every day I am finding more things I hate with this update.  I'm so disgusted with my brand new S10+  right now. 

Apprentice
Just seen a Twitter post suggesting that the was a JLR software update released a few weeks ago, but looks to be a dealer install (or can we use the JLR software updater for the SD card!?)


https://twitter.com/kjm_uk/status/1109511842781646849?s=19
Apprentice

Same problem for me, using an S9 with an XE. Samsung have told me to contact Jaguar

First Poster

I went to Jaguar last week ,and with the last firmware of Jaguar its same

Explorer

@DrMatt wrote:
Just seen a Twitter post suggesting that the was a JLR software update released a few weeks ago, but looks to be a dealer install (or can we use the JLR software updater for the SD card!?)


https://twitter.com/kjm_uk/status/1109511842781646849?s=19

Does anyone know if this was for the "Incontrol Touch"? My local dealer only knows of an update for the "Incontrol Touch Pro" (Germany)....  

Apprentice

My car is booked in to be looked at Monday so I'll update what they find

New Member

Having the same issue with Evoque, tried all forms of fix (cache clearing etc), Galaxy S8 plus worked fine until PIE software upate and now we just received our new S10 Plus handsets and all have the same problem connecting to the Evoque resulting in same issues of 10 sec on and 10sec off constantly via bluetooth, we have a few iphones also and they work fine with no issues, I have  contacted local Land Rover dealer and signed up for the land rover TOPIx site that supplies any software updates etc and both online and dealer have both advised that there is no software updates for the cars bluetooth system. What now Samsung? 

First Poster

I am having this exact same problem. As soon as I updated to PIE, my Galaxy S8+ bluetooth stopped working properly in my Range Rover Evoque. SAMSUNG ANY REACTION Please!!!! 

First Poster

I am having this exact same problem. As soon as I updated to PIE, my Galaxy S8+ bluetooth stopped working properly in my Range Rover Evoque. SAMSUNG ANY REACTION Please!!!! 

Just Browsing

I am having the same exact problem. Have called SAmsung three times. They have sent me to my Rangerover dealership and Verizon. Both have confirmed that it is a Samung issue. When will the issue be fixed? 

Top Liked Authors