Support

Open search

Bluetooth audio not working from Google Play Music

SOLVED
Apprentice

My Galaxy S9+ used to work with my car stereo and bluetooth headphones, but in the past month, it has stopped working.

 

The device is paired, and connected via bluetooth, and I can play music using Amazon and also YouTube, so it's not a fault with the bluetooth device, nor an issue with the connection.

 

However, the audio from Google Play Music is always directed to the phone's speaker.

 

I also have a Samsung Galaxy S7, which works perfectly with both bluetooth devices.

 

WHAT I'VE TRIED SO FAR

1. Rebooting my phone

2. Switching on/off the bluetooth devices

3. Unpair / Reboot / Pair the bluetooth devices

 

The fact that it works with Amazon Music and YouTube, implies to me that it's a problem with the Google Play app.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Apprentice

I have a solution.

 

There are two settings that need to be tweaked.

 

The first is found here...

 

Settings->Sounds and Vibration->Separate app sound

 

Originally, this was set 'On' and as soon as I turned it 'Off' I was able to hear music on my headphones.

 

The second setting is here...

 

Open Samsung SmartThings app

On the top right of the screen, there are 3 dots, tap them, and choose 'Settings'

At the top, there is a setting called 'SmartThings Panel' if this is off, turn it on

 

Once it's on, a little panel is displayed, if you have 'Separate App Sounds' switched on, there will be a little speaker icon on the SmartThings panel, which lets you choose which output device to use. 

 

You should be able to turn the 'SmartThings panel' off once you've got it working, but I needed to turn it on to select my headphones.

3 REPLIES 3
AndrewL Moderator
Moderator
Hi @RichieRich

It seems as though streaming services are syncing fine with your headphones however your personal library of music is having issues. You may wish to try moving a few of your songs into the Google Play Music library to see if you are able to receive these tunes through your Bluetooth headset. If you can then, although it's not ideal, you may wish to import your whole music collection to Google Play Music as means of working around the issue.
Apprentice

I'm not sure what you mean by moving songs to my Google Play Music Library.. these songs are already in my library.

Highlighted
Apprentice

I have a solution.

 

There are two settings that need to be tweaked.

 

The first is found here...

 

Settings->Sounds and Vibration->Separate app sound

 

Originally, this was set 'On' and as soon as I turned it 'Off' I was able to hear music on my headphones.

 

The second setting is here...

 

Open Samsung SmartThings app

On the top right of the screen, there are 3 dots, tap them, and choose 'Settings'

At the top, there is a setting called 'SmartThings Panel' if this is off, turn it on

 

Once it's on, a little panel is displayed, if you have 'Separate App Sounds' switched on, there will be a little speaker icon on the SmartThings panel, which lets you choose which output device to use. 

 

You should be able to turn the 'SmartThings panel' off once you've got it working, but I needed to turn it on to select my headphones.

Top Liked Authors