Support

Open search

Background data issues

First Poster

Hi All, i was wondering if you could pls help me with the following issue: I have recently purchased a Samsung S9+ mobile phone, dual hybrid sim, which appears to have what I believe are background data related issues.  In particular, if I stop using the phone and leave it on standby for approx 1-2 mins, the phone stops recieveing any data related messages (e.g. emails, whatsapp, ebay).   If I start using the phone again, I have to go into the relevant apps (email, whatsapp, etc) in order for all messages to come through.  It is as if the background data automatically stops / goes "to sleep" for all apps if I don't use the phone for a couple of minutes and then I have to go and open the relevant app for it to syncronise with its server and "wake up" again.  This only afects apps that rely on data. Phone calls and SMS text messages are not affected. I've checked the phone's data related settings, including Data Saver (whcih is "off"), Auto Sync data (which is on for all accounts), and I can't resolve the issue. I've also asked my internet provider for a new sim card and used it, but it made no difference. This is very frustrating because it means that in practice I have to keep checking my phone to see if I have received any messages.  Any suggestions/ideeas would be much appreciated!

6 REPLIES 6
AntS Moderator
Moderator

Hi @Mike100

 

Sounds like the sleeping apps battery optimisation feature in Pie/One UI.

 

Settings > Device Care > Battery > 3 dots (menu)  > Settings > Sleeping Apps; and remove any of the apps you want to keep awake from the list.

 

Let us know how it goes.


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

First Poster

Hi @AntS, many thanks for your message and for trying to help me.  I've followed your suggestions, i.e. went to: Settings> Device Care> 3 dots menu> Settings> Sleeping Apps, but I have no Apps under Sleeping Apps. 

 

However, by following the same path (i.e. Settings> Device Care> 3 dots menu> Settings) I found the "Adaptive battery" option, which could be disabled. There are also a number of other functions which could also be disabled such as "Optimise settings", "Auto disable unused apps", etc.  

 

For now, I've tried the following less "invasive" alternative: I went to Settings> Device Care and then clicked on batter icon (the first icon at the bottom left of the screen), then, then I clicked on "Battery usage", then I scrolled down to and clicked on WhatsApp, and then I clicked on "Optimise battery usage" and then selected "All" aps, then scrolled down to WhatsApp and moved the slider to the left (i.e. I disabled battery usage optimisation for WhatsApp). The same for Outlook and any other app that i needed. Then I restarted the phone. I'll let you know later today if it makes a difference. 

 

many thanks again!

 

First Poster

Hi again @AntS, I've tried all the various options set out below and unfortunatelly none of them worked...   It therefore  doesn't look like it's a battery optimisation issue...

 

The only ways to receive emails and messages after not using the phone for a few minutes is either if I open the email/messaging app, or if I turn the Airplane mode on and then off (i.e. turn data off and then back on), after which the emails and/or messages show in my inbox...

 

Any other suggestions please?

AntS Moderator
Moderator

If you've not sone so already, might be worth checking the background data usage settings of the individual apps themselves via the Apps manager. Settings > Apps > (All ) > [click into the relevant app] > Mobile data, and see if 'Allow background data usage' is enabled. Plus whilst you're in that app's settings menu, check Battery > and that 'Allow background activity' is enabled. 


Prince_Community_Sig03.jpg

 Say "Hello!" to the Community in The Introduce Yourself Thread.

First Poster

@AntS: thank you again, I checked that 'Allow background data usage' for each of my email and messaging apps is enabled.

 

Unfortunately, I couldn't find the "'Allow background activity" option you are referring to - could you please help me find it?

Explorer

There is no background data issue. It is purly firmware issue and samsung has to release patch for it. If you lock your phone screen and leave it for 5 mins you won’t get any notifications. In this case its battery saving gone to deep sleep mode. Even if you disable, it treat as sleeping mode. My s9+ repaired many times and came back with same issue. Replaced with brand new one and same issue. This notification issue affected so many people since last year Pie update. Samsung is not responding properly but they are very well aware about this issue. No matter whatever you try to solve it doesn’t work. There is one unofficial way to do it via adb command but I do not advice as this is not official and you may endup with battery issue later. If you have a time search on google “ notification issue affecting all range of galaxy devices” and it will come up. Hopefully samsung will release patch soon. Meanwhile use your mobile as a paperweight.

Top Liked Authors