Support

Open search

Anonymous phone calls, "Block Unknown Number" does nothing at all to block numbers

New Member

Just purchased a Galaxy S9+, and I am receiving calls from anonymous numbers.  I've gone into the call settings and activated the "Block Unknown Numbers".   However, I still receive calls that are anonymous.  My question is, what is this feature for and am I misunderstanding what it is supposed to do?

 

I figured it would auto-reject anonymous numbers, or perhaps any number not stored as a contact, both of which are fine with me.  But, like I said above nothing changed at all after activating this feature.  Anyone else have this problem, or is it a known issue?  I'm not having much luck on this topic doing web searches.

5 REPLIES 5
Explorer

Hi, i have the S9+ and i use it as my main driver, i dont know if mine works as i dont think ive recieved any uknown calls yet. That been said i have checked the android security software updates page which shows 2 security updates are coming soon, which may cover your issue. I have included pictures of current OS and application software versions and any information etc for reference.

 

I have listed below somethings that you could try if you havnt already:

 

Have you got the latest software updates for your phone application and operating system ? Software updates usually fixes issues, especially with the fact the S9 models have not long been released and therefore may have glitches in the operating system.

 

Have you tried resetting your mobile network settings and reinstalling your carrier settings.

 

Have you tried turning off the block unknown caller, then force stopping the application in your settings then starting the phone application again and turning on block uknown callers again.

 

All that failing and you need an alternative to stop unwanted calls then can download a call blocking application from the play store, i had a quick look for you and i found one called whoscall which is an editors choice, ive attached a picture so you know what it looks like.

 

I hope this somehow helps. Chances are though it will be another glitch that Samsung need to fix

 20180415_123436.jpgAndroid security bulletins.

 

20180415_123507.jpgCall blocking application.

 

20180415_123532.jpgCurrent phone application version.

20180415_124355.jpgOS version.

 

First Poster

It doesnt work for me either.  I get spam calls all freaking day.  My old s5 Active used to autimatically send every call not in my contacts list to voicemail.  My phone would only ring if you were in my contacts list.  This feature appears to be completely broken in the s9.  Very frustrating.

New Member

It doesn't work on my s9 either, even after my s9 has just been updated to the latest software. I got spam call every day

New Member

I am now trying to enable "smart call", and activate "Do Not Disturb" (excepting contact only but message from all). Will see if these help

New Member

I have a Samsung S9, and I just set the "Block Unknown Number" yesterday and I'm still getting lots of scam calls - a sudden surge of scam calls - stating they are the Social Security Administration and my SSN has been compromised.  i have received 5-6 of these calls every day with a slightly different number.  They leave a voicemail with the exact same message.  I finally had to turn off the sound because it was getting so annoying.  How do I get the calls to stop?

Top Liked Authors