Support

Open search

S20 Ultra 4G Signal Loss?

Highlighted
New Member

Hello all,

 

Anybody else having issues with 4G Data on S20 Ultra, using the Three network?

 

When I use my S20 Ultra's 4G data, I'm having problems with what seem like freezes, similar to packet loss on a household Internet service.

 

WhatsApp messages will hang with the timer, webpages/twitter app will buffer constantly. I'm now having issues with calls cutting off, and whatsapp video calls constantly "Reconnecting". If I turn Airplane mode off/on, it restores connectivity (Until the next freeze)

 

I've reset my network settings, re-seated and cleaned sim card, restored the phone back to factory settings, changed data settings to 4G/3G only...and also contacted Three, who say they don't see any issues at their end

 

 

For the record, its been like this since the day I received it, (9th March) so I'm not sure if its related to network congestion, due to the Pandemic.

 

 

3 REPLIES 3
Highlighted
New Member

@MKBrodie wrote:

Hello all,

 

Anybody else having issues with 4G Data on S20 Ultra, using the Three network?

 

When I use my S20 Ultra's 4G data, I'm having problems with what seem like freezes, similar to packet loss on a household Internet service.

 

WhatsApp messages will hang with the timer, webpages/twitter app will buffer constantly. I'm now having issues with calls cutting off, and whatsapp video calls constantly "Reconnecting". If I turn Airplane mode off/on, it restores connectivity (Until the next freeze)

 

I've reset my network settings, re-seated and cleaned sim card, restored the phone back to factory settings, changed data settings to 4G/3G only...and also contacted Three, who say they don't see any issues at their end

 

 

For the record, its been like this since the day I received it, (9th March) so I'm not sure if its related to network congestion, due to the Pandemic.

 

 


I haven't found a fix but I got this problems aswell. I am not using three network so i think it's a global bug or problem.

 

Sometimes my range just drops to 0 and my 4g dissapears. Then when turning  airplane mode on and off it comes back.

 

Hope they fix this asap or if anyone has a solution. 

Highlighted
New Member

I am having the exact same issue but not with 3. When I run a speed test I am only getting 2mb if that on download and the upload doesn't even move. I put the sim in my old s10+ and I am getting 60mb plus in the same spot. 

 

Have you found a solution for this? It is really frustrating me now. 

Highlighted
New Member

I am relieved to see that I am not the only one experiencing these problems. I have tried to do more or less everything to find out if the problem is isolated to my phone only. Here in Norway, my phone shows the same symptoms as described. Also from the day I received it. Voice and data communication over 4G/LTE seems to hang even though I, in Samsung terms, have acceptable signal strength. (A Huawei phone with the same SIM-card at the same spot has more than 5 to 10 dBm better signals). Additionally, the Samsung Galaxy S20 Ultra has poor upload performance on 4G/LTE networks compared to cheaper phones.

It surprises me that such an expensive phone has basic problems like this. I hope indeed that they will be able to fix the problems through software updates, preferably sooner than later.

Top Liked Authors