Support

Open search

Samsung S10 does not prefer neither roam to WiFi on 5Ghz band

First Poster

I was wondering why Samsung Galaxy S10 does not roam/switch to WiFi on 5 Ghz - when available.

The mobile phone stays in congested 2,4 GhZ WiFi band in spite of roaming to the better 5GhZ Wifi even if the accesspoint does suggest to roam to 5GhZ.

 

Can you please help me with this? Why is there no setting "prefer 5GhZ" on Wifi config ? (In hotspot config - advanced options there is a selection available).

15 REPLIES 15
Pathfinder

That is strange. I have Unifi ubiquiti AC-AP-LR routers in my house. They have a setting (although in beta) where they "force" devices to use 5g if possible.
The problem that my s10e keeps dissconecting from time to time between the routers is another thing.
It would help if you gave us the model of your router?

First Poster
Yes I experience the very same issue!

My Samsung S10 does ALSO NOT roam to the better 5GhZ WiFi band, but stays in 2,4GhZ.
Allthough I do not see any setting that might help here.
My Accesspoint is also from Ubiquiti (Unifi AP-AC-PRO) and the setting "prefer 5G" is set there to true.
Pathfinder

Go around the net. These routers while being very good have had a known problem with Samsung for a long time. The new router firmware did not fix anything. Sadly.

Strange. While you cant connect to 5g mine does but disconnects. Id check on the official user forum of the router company. This forum is dead like my racer dreams.

First Poster
Another Issue I found with Unifi hardware (vendor Ubiquiti) using Samsung Galaxy S10 is, that if I want to choose a cutom DNS (advanced connecion options in Android settings) it drops the internet connection in TOTAL!
Internet connection (reply) only recovers if the setting is "off" or "automatic".

Well, I am very surprised that on ALL devices I had so far the UniFi hardware does not cause any issues, more: They work perfectly, but the new Samsung Galaxy phone, it does not roam to 5 GhZ mainly and does cause some wierd DNS/internet connection "drops".

I would be glad, if technicans from Samsung could be aware of this issue and post a reply here.
Pathfinder
This user generated forum hosted by Samsung. I rarely see people here much less will there be a Samsung representaative. My brothers s9 has the same issue
Pathfinder

Disconnections were possibly resulted from signal jumping, this one is the phone connects to 5GHz from 2.4GHz and vice versa.  If the phone is connected to 5GHz and you go further way from the router it will signal jump down to 2.4GHz. 

 

The primary differences between the 2.4 GHz and 5GHz wireless frequencies are range and bandwidth. 5GHz provides faster data rates at a shorter distance. 2.4GHz offers coverage for farther distances, but may perform at slower speeds.

 

Suggests to open your router GUI, set the band to 5GHz only, and not dual(5GHz and 2.4GHz), this should lock your phone to 5GHz only. Thanks.

First Poster
A follow up from my side:
all of a sudden the S10 does connect to the 5GhZ Wifi allthough the SSID names of the WiFi network is the same for both 2,4 and 5GhZ band.
Until now I do not experience any connection issues.
I will keep watching the behaviour, and if it gets worse (again) I will write here a response.

@lunaticore:
Thanks for the input; yes indeed having separated SSID names for both bands would be worth to try as it forces the device to connect to 5Ghz.

@Venom7000:
Perhaps it is related to your settings on the UniFi Controller (Bandsteering is enabled at my end)?
There was an update of the APs recently, are you on latest 4.0.42 version for your UniFi APs?
Pathfinder

Hi, yes the latest.

I fixed my problem 2 days ago. By simply turning off the "network optimiser" and "forcing high performance devices on 5ghz".

 

My device still connects to 5ghz by itself. And I dont have problems with my weak signal and wifi connection drop.

 

TURN OFF THAT BETA FEATURE IMMEDIATELY. It seems to fix all the problems on the latest firmware.

 


 

Navigator

This is not a good fix 

Top Liked Authors