Open search

Mobile Data Not Working (Sim2)


So I have a S10+ running the latest software as of today.


Sim 1 has a three uk pay monthly sim inserted and calls, texts and data has always worked. Sim 2 has a Vodafone Pay Go sim inserted while calls and texts work, data never has worked.


Access Point Names have their correct APN's set:


Sim 1 : 3 (

Sim 2: Vodafone PAYG Internet (






I have also tried manually adding the APN as per:


If I select sim 1 for mobile data then it works:

Screenshot_20191101-124206_One UI Home.jpg


If I select sim 2 for mobile data I have no internet access at all:

Screenshot_20191101-124218_One UI Home.jpg


I have had this issue since day 1 so I know it's not an issue with the current software version. I have checked my vodafone account and there are no bars in place so it should work right? I guess I could try and find another handset to test the Vodafone sim in but if anyone can offer any pointers that would be great!

I have spoken to Vodafone and they say there are no restrictions in place on my account and that my phone is showing a missing/no APN settings error their end even though the APN is set and active under sim 2 Access Point Names.
Well it was an account related issue after all! I had to enable Data Barring on the account and then disable it. Working now. :/
Top Liked Authors