Open search

Android Auto with Mercedes

First Poster


I was hoping someone can help. 


I have recently purchased a Samsung S10 and this is the first I have used one.

I'm trying to setup up Android Auto but not having any joy. I have a 2019 Mercedes E Class, the automatic start isnt appearing and the car isnt reconising the phone. I have tried the usb that came with the phone for charging as well the usb wire from Mercedes for Samsung phones.

Could this have something to do with app permissions.  Any help would be apprciated. 


Thanks in advance


First Poster

I am having the same issue, it's definitely the phone and not the car as I have tried it in 2 different cars with fully working Android Auto features and neither recognise my phone. 

It was working when I first got it in my car then all of a sudden just stopped one day and I've yet to figure out why. I've had a couple of suggestions from Samsung (not sure if they will work) but havent had time to try.

Will let you know if I manage to resolve. Really not happy about it. Samsung did at first try to fob me off with going back to my car manufacturer but once I let them know it didnt work in 2 cars I think they realised it was the phone at fault. 

First Poster

I'm also in the same boat as are a lot of other users in the US.


I have tried clearing the app cache and soft restarting the phone as Samsung have suggested but this has no effect. 


My phone is an S10+ and the car head unit is in a Peugeot 3008.


Android Auto works fine with my Huawei P20 Pro but not with my S10+ 

Interestingly when I connect (with the original) USB cable I see the Android Auto and Mirror Link icons flashing on and off on the car stereo - it's almost like the service that's running on the phone keeps restarting or isn't detecting something properly. I've tried changing the USB mode to charging only, data transfer, photo transfer etc but it doesn't seem to help.

First Poster
Has anyone been able to find a resolution?
Do Samsung themselves not comment on this discussion board?
First Poster

Mines was fixed with a soft reset of the phone but mines did work to start with so not sure if that will help you or not? 

First Poster

No mine still doen't work, even with the latest firmware update and Android Auto update 

Top Liked Authors