Support

Open search

Samsung Galaxy A40 won't play music when in sleep mode

First Poster

I purchased a Samsung Galaxy A40 from Currys PC World yesterday and today has been my first day using it. Overall I have been really impressed with it and its features. Although I was listening to music from Spotify on it today and I put the phone it to sleep mode (by pressing the power button for about a second) and after about 30 seconds the song that I'm was listening to then paused. When I woke up the phone, the song then started playing again. I didn't have to unlock the phone for the music to restart playing.  I then let my phone go into sleep mode by itself but the same problem kept occurring. I've tried reopening and closing the Spotify app but I still have the same issue. Also, under settings, I have turned off "put app to sleep" mode but this didn't have any effect. 

 

I then wondered whether the problem only related to Spotify so I decided to try some music I had previously downloaded from Google Play Music. I then played the music from Google Play and the continuously keep playing. 

 

I never have had this problem before with Spotify on any other device. I also have a Samsung Galaxy Tab A tablet and don't have this issue. Also, my previous phone was a Sony Xperia E4 and I never had issues with playing music from Spotify on this either. 

 

Is anyone else having the same issue?  Does anyone know why I would be having this issue just with Spotify and are there any solutions? 

 

Many thanks in advance

4 REPLIES 4
Highlighted
CarlH Moderator
Moderator

Hi @Christian_02. If you go to Settings > Device Care > Battery. Check if Spotify is listed here and if you tap on it and see if 'Put app to sleep' is active. Let me know how you get on. 

First Poster

@CarlH wrote:

Hi @Christian_02. If you go to Settings > Device Care > Battery. Check if Spotify is listed here and if you tap on it and see if 'Put app to sleep' is active. Let me know how you get on. 



@CarlH Hi, thanks for your response. I've followed your instructions and checked this setting. Currently it is deactivated. Should I turn it on so it is activated? 

AndrewL Moderator
Moderator
@Christian_02: Leave the 'Put App To Sleep' option deactivated for now. If you go to Settings > Apps > Spotify > Battery > Allow Background Activity > On, does this resolve your query?
First Poster

Hi, I've followed the instructions and turned the 'allow background data' setting on and it still hasn't had any effect unfortunately. Many thanks for your responce though. Is there anything else I could try?

Top Liked Authors