Open search

Samsung A50 Gopro hero 7 connection problem

First Poster

@BAss1 wrote:
Made my working yesterday. Was keep resetting settings, reconnect camera good several times. What I did I remove auto reconnection stick from my house wifi, and kept auto reconnect for gopro. And its worked. Was able to watch all my videos.

You have a50 also? I have same issue so will try this if so

First Poster

Same Issue here, no way to connect a Gopro7 to the A50. I saw your solution too late XD.

First Poster
Please @samsung provide a update
First Poster
Ive made it work.

- deleted the app and reinstalled it

- deleted the gopro in the wifi history of my a50

- deteted the gopro in the bluetooth history of my a50


This was the most important thing i gues

- factory reset my gopro

After the reset, i turned on my gopro, follow the instructions on screen and when it started pairing on the gopro, i looked on my wifi connections on the a50 and saw the gopro in the list. I then connected to it with the gopro name and password provided on the gopro screen.

I then opened the gopro app on my phone and it automaticly found my gopro and connected right away.
I did the same (without factory reset go pro) and it worked. Thank you TimDH0252
First Poster



I have an A 50, and a ho pro hero 7 black as well.

Open wifi connection, and select your wifi connection j currently connected. In new window select connect automatically. Just turn it off. Done
First Poster

I'm not connected to any wifi. I'm in a different country, using mobile data. I haven't been on wifi in the past 2 months 

New Member



I just realize that Samsung have some mechanisms to prevent you from connecting in Wi-Fi networks without internet access... They make the connection from camera like "invisible" because you are already connected in a Wi-Fi... I did the steps that guy said and now I feel awesome using my Hero 7 Black with my A50 ... Everything has a solution, you don't need to change your phone lol, just need to look for it.




every one who read this is looking for a solution, lol. i have the problem that it worked only one time. somebody else have this problem? sorry but to reinstall the app and do all steps again its not a good solution.

Top Liked Authors