Support

Open search

My Samsung A40 is not working properly. It can happen. Assistance in Portugal sucks!

SOLVED
Apprentice

I have a Samsung A40, a corporate mobile! Brand new. After some weeks it started to disconnect the SIM. Several times a day! I have dropped it and picked it up 3 times. I was told each time the phone was good! Apparently, last time it was send to Samsung. Still has the exact same problem.

This is unacceptable for a phone wich was unbox just a few week ago. I should have been given a new one. Don't know what to do. I can use my time better than dropping and picking up my mobile at resale point.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Apprentice

I discovered the solution on my own. When Google acount reinstalls the apps, the ones or some that uses information from SIM card seems to have not been installed properly or are corrupt. Had to identify which of them were corrupt, desinstall and install again. It works fine now.

View solution in original post

8 REPLIES 8
Highlighted
Superuser I
Superuser I

Hi @ruivieiradias 

 

If your company has provided the phone to you as you mention it's a "corporate phone" then perhaps go back to your company and ask for a replacement. 

 

As a process of elimination can you try your sim card in another phone and then see what happens.

 

This can help determine if its the sim card or network signal at issue.

 

If this happens in another phone then perhaps your sim card needs replacing via a sim swap.

 

I wish you all the best with this situation. 

 

 

My advice comes from being a UK Samsung Phone User.
Current Phone ~

Samsung Note 10+ 5G _256Gb > Model: SM-N976B._ Samsung One Ui 2.1 / Android 10.

Samsung Gear s3 Frontier Watch.
Samsung Galaxy Buds.
Samsung Galaxy Tab A {2016}SM-T580

Highlighted
Apprentice

I discovered the solution on my own. When Google acount reinstalls the apps, the ones or some that uses information from SIM card seems to have not been installed properly or are corrupt. Had to identify which of them were corrupt, desinstall and install again. It works fine now.

View solution in original post

Highlighted
Explorer

Hi, i have the same problem. Do you remember which apps you had to reinstall? Thanks!

Highlighted
Apprentice

It was a portuguese app. It should be an app that uses contacts. I was lucky to fund out easily which was out. When I installed all apps I didn't set them up imediately and just when I needed them. So, the first time I used it, the error started so I knew which app was creating the problem. I desinatalled it and installed again and it was fine. What I mean by an app that uses contacts is for example Whatsapp.

Highlighted
Explorer

Thanks a lot! I'll try to go through my apps that use contacts - hopefully, that improves the nasty "No SIM card" error on my Samsung Galaxy A40... There are quite some guys having the same issue here in Germany ...

Highlighted
New Member

I solved the issue by deinstalling (and then new installing) Android Car App. Now the Phone works fine.

Highlighted
New Member

unfortunately i have had over 10 different phones with the same issue and have not found a proper solution yet.

Lots of my college's are really struggling with this issue since everybody is working at home.

 

Is there anyone here with a defenitive solution? I would really apreciate it. Thanks in advance!

Highlighted
Apprentice

Desinstall all apps that uses info of your sim card and install them again. Example: whatapp, skype... It worked for me.

Top Liked Authors