Support

Open search

How to disable notification panel on lockscreen?

Highlighted
SOLVED
Observer

While the phone is locked with a pattern, it is still possible to pull down and use the notification panel.

 

The wi-fi turns on and some data starts downloading, the torch turns on and discharges the battery, while the phone is in my pocket and is supposed to be locked.

 

This interface design is so bad.

 

How to stop this from happening?

1 ACCEPTED SOLUTION

Accepted Solutions
AndrewL Moderator
Moderator
@alikim: It isn't possible to disable the Quick Settings panel on the lock screen, I'm afraid, although if you have security in place such as a pattern or PIN then features such as W-Fi should still require the phone to be unlocked in order to be activated. What I'd suggest is making sure that you hit the Power button so the screen goes to sleep before putting the phone in your pocket. You can also go to Settings > Display > Accidental Touch Protection > On to help combat this issue. Hope this helps.

View solution in original post

8 REPLIES 8
Superuser I
Superuser I
Simply go to the lock screen settings and turn notifications off. That will effectively prevent notifications from being shown on the lock screen.
Observer

You didn't even read my question, is this an auto generated reply?

 

I'm NOT taking about notifications, I'm taking about the whole notification panel that you pull down from the top of the screen with all the setting for the phone.

Superuser I
Superuser I

Honestly, I dislike your rude response, I wish you the best of luck in the future. I won't be spending more of my time in an effort to assist you.

My final advice is to read my response properly, especially the "lock screen settings part".

Just to be clear: I have no obligation to answer to you. I am spending my own free time in an effort to assist other costumers, I won't stand for any rude behavior and bluntly stated: I have better things to do than to reward such behavior.

 

To answer your question: No - That was not an automated response (In fact, none of my posts are automated). 

Observer

Well, just to be clear, "lock screen settings part" disables notifications on lock screen, which I have turned off already, and I'm taking about notifications panel.

 

If you have no idea what that is, maybe you shouldn't post your rubbish here because it has nothing to do with my question, which you need to read and comprehend before answering.

 

I don't know what makes you think you are helping people while in reality you just trash people's threads with irrelevant informations that is of no use.

Superuser I
Superuser I
I wish you the very best luck in the future. I will not be spending any more time in order to try to assist you.

With honey you attract more flies than with acid But with the tone of your text I believe that it is more likely to scare others away. I genuinely hope that someone will give you a response you like but I prefer to spend my time on people that do appreciate my efforts
AndrewL Moderator
Moderator
@alikim: It isn't possible to disable the Quick Settings panel on the lock screen, I'm afraid, although if you have security in place such as a pattern or PIN then features such as W-Fi should still require the phone to be unlocked in order to be activated. What I'd suggest is making sure that you hit the Power button so the screen goes to sleep before putting the phone in your pocket. You can also go to Settings > Display > Accidental Touch Protection > On to help combat this issue. Hope this helps.

View solution in original post

Observer
Thank you for the reply, I a security pattern, nevertheless, wi-fi and torch can be definitely turn on before I enter the pattern.

I don't have any touch protection settings, I do press the Power button every time to put the phone to sleep

After that, if you accidentally press Power button while your phone is in your pocket then the panel can be opened used and fully functional.

I honestly can not believe that Samsung is unable to make a phone that has a lock screen which is like "really locked locked" and nothing can be done to fix this.
AndrewL Moderator
Moderator
@alikim: As a Pattern is classed as a medium security measure, please can you try switching to a PIN or password to see if this helps? I tried with a PIN in place, and was unable to enable or disable Wi-Fi, Bluetooth and other such features via the Quick Settings menu without entering the PIN. Let me know how you get on.
Top Liked Authors