Support

Open search

Cannot use home WiFi network with A50

Observer

The past couple of days I've not been able to use my home WiFi, either 2.4g or 5g, with my A50. I can connect to both, but only to recieve the message that "internet may not be available". Resetting the router has made no difference, and in any case every other device in the house is working as usual, so I'm worried the issue might be my device.

 

I've tried a few different things, forgetting and reconecting to the networks, restarting the device, running the device in safe mode, resetting network settings and wiping the cache - nothing has made any change yet! Any more suggestions about what the issue may be and how to fix it would be much apreciated.

4 REPLIES 4
Navigator
Hey Lu-mon!

Sounds like you've got troubleshooting down to a T! I'd recommend checking the Power Saving settings. As Wi-Fi does use up some of the A50's energy, Power Saving mode can disable a connection. Head to Settings > Device Care > Battery > Power Mode > Optimised.

Also, is it just the home Wi-Fi you're experiencing a problem with or is this any Wi-Fi connection?
Observer

Hi Chelsea, thanks for the response.

 

Looks like it's already set to optimised. As for the second question, that's something I'd like to check but unfortunately I'm recovering from surgery at the moment so I've not had the chance to go anywhere to test this out.

Highlighted
CarlH Moderator
Moderator

Wishing you a speedy recovery, @lu-mon! Short of performing a Factory Reset, it sounds like an engineer inspection might be called for. This link will direct you to the closest Service Centre in your area. If you prefer, I can arrange a courier to collect your phone. 

Observer

Hi Carl, thanks for the info, I wouldn't have thought there'd be a service centre local to me but looks like that will be my best option.

 

I'd hoped to avoid doing a factory reset just for the inconvenience, but fortunately I've not had the phone for very long so not too much of an issue to back everything up. Unfortunately, I've given it a go and still not resolved anything. I've also tried setting up a mobile hotspot on another device and connecting to that, but still recieve the same "internet may not be available" message.

Top Liked Authors